[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[rhelv5-list] Issues with RHEL5 and PV Xen RHEL4



Hi there,

I'm currently running RHEL 5.1 64-bit fully patched and kernel 2.6.18-53.1.4.el5xen on a Sun x4200 M2 (8GB, 4 cores). I am attempting to install RHEL 4.6 32-bit (kernel 2.6.9-67xen) as a paravirtualised guest.

Within the RHEL5 Dom0 I start the guest using "xm create -c template" and the below configuration file.

##################################################
kernel = "/etc/xen/vmlinuz4"
ramdisk = "/etc/xen/initrd4.img"
name = "template"
memory = "4096"
disk = [ 'tap:aio:/VM-storage/template,xvda,w', ]
vif = [ 'bridge=xenbr0', ]
vcpus=2

on_reboot   = 'destroy'
on_crash    = 'destroy'
##################################################

The kernel and ramdisk are from the RHEL 4.6 install tree which is located on an HTTP-accessible web server (running Apache, local subnet). The file /VM-storage/template was created using the command

dd if=/dev/zero of=/VM-storage/template oflag=direct bs=1M seek=409600 count=1

Every time I try the install manually (I haven't figured out Xen kickstarting yet, suggestions on how to provide a kickstart file to the DomU please?) I whistle through the setup screens and then let the installation start the package installation, at which point it slows to a crawl or even stops on a package with the status "Installing...". The web server is definitely not overloaded as I've kickstarted ten RHEL5 boxes before now concurrently with no slowdown.

However the worst is yet to come... Usually after a little while of installing the RHEL4 kernel panics and I'm dumped back out to Dom0. I've tried this with the previous RHEL 4.5 media (copied to the web server) too. It tends to fail earlier.

Here's the most recent error during text-mode installation:

Oops: 0000 [#1]
SMP
Modules linked in: dm_snapshot dm_mirror dm_zero dm_mod ext3 jbd msdos raid6 raid5 xor raid1 raid0 xenblk xennet sr_mod sd_mod scsi_mod cdrom loop nfs nfs_acl lockd sunrpc vfat fat cramfslements
CPU:    0
EIP:    0061:[<c01496c9>]    Not tainted VLI
EFLAGS: 00010287   (2.6.9-67.ELxenU)
EIP is at zap_pte_range+0x279/0x489
eax: 00037000   ebx: 00000002   ecx: f5392000   edx: 00000000
esi: 001163b1   edi: c6c8d9a0   ebp: 00000000   esp: ec1bae04
ds: 007b   es: 007b   ss: 0068
Process anaconda (pid: 419, threadinfo=ec1ba000 task=ec3a3830)
Stack: 163b1067 00000001 00000000 00000000 00000000 00000000 00037000 0c800000
       c347d2a0 cf23a328 0c837000 00000001 0c800000 c0149980 c347d2a0 cf23a320
       0c800000 00037000 00000000 0c7b7000 d0df6008 0c837000 00000000 c01499e5
Call Trace:
 [<c0149980>] zap_pmd_range+0xa7/0xcb
 [<c01499e5>] unmap_page_range+0x41/0x65
 [<c0149ad6>] unmap_vmas+0xcd/0x1e8
 [<c014ec19>] exit_mmap+0x85/0x15b
 [<c011a2d9>] mmput+0x52/0x77
 [<c011a74b>] copy_mm+0x36c/0x396
 [<c011b26a>] copy_process+0x6b5/0xb0b
 [<c011b7ad>] do_fork+0x8a/0x16b
 [<c0127372>] sigprocmask+0xb6/0xd0
 [<c0127423>] sys_rt_sigprocmask+0x97/0x14c
 [<c0105cd7>] sys_fork+0x16/0x1a
 [<c010734f>] syscall_call+0x7/0xb
Code: 8b 4c 24 14 8b 41 04 85 c0 75 0a 83 39 00 0f 45 c1 89 44 24 14 c7 44 24 10 00 00 00 00 8b 44 24 18 39 44 24 10 0f 83 08 02 00 00 <8b> 55 00 8b 4d 04 85 d2 75 08 85 c9 0f 84 e6 01 00 00 88 d0 a8
 <0>Fatal exception: panic in 5 seconds
Kernel panic - not syncing: Fatal exception

All of my xen stuff appears to be at version 3.0.3-41. Does anyone have any suggestions what I'm doing wrong or what is happening, please?

Ben
--
Unix Support, MISD, University of Cambridge, England
Plugger of wire, typer of keyboard, imparter of Clue
        Life Is Short.          It's All Good.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]