[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [rhelv5-list] system update blues





On Wed, Jan 13, 2010 at 9:00 AM, Chris Adams <cmadams hiwaay net> wrote:
Once upon a time, Mirko Vukovic <mirko vukovic gmail com> said:
> Hello,
>
> I am updating my rhel5 system after about six months.  The package updater
> quit with a long list of unresolved dependencies.
>
> I tried cleaning the cache, but that did not help.
>
> I am now trying to do the update with `yum update --skip-broken'.  After a
> download of some 675M's the install stalled again because of error messages,
> which I am not sure how to handle.  Here is the transcript for `nspr':
>
> [sm CYSSHD1 mv]$ sudo yum install nspr

If you already have nspr installed, then you want "yum update nspr"
instead.

> ERROR with rpm_check_debug vs depsolve:
> nspr is needed by (installed) nspr-devel-4.7.3-2.el5.i386
> nspr is needed by (installed) nspr-devel-4.7.3-2.el5.i386

You appear to also have nspr-devel installed, and it depends on the
matching version of nspr.  IIRC "yum update" will pull in the
dependencies for you (or you could do "yum update nspr\*").


I get the same error.  Here is the transcript:

yum update nspr\*
Loaded plugins: downloadonly, rhnplugin
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package nspr.i386 0:4.7.6-1.el5_4 set to be updated
---> Package nspr.x86_64 0:4.7.6-1.el5_4 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

===================================================================================================
 Package         Arch              Version                   Repository                       Size
===================================================================================================
Updating:
 nspr            i386              4.7.6-1.el5_4             rhel-x86_64-client-5            119 k
 nspr            x86_64            4.7.6-1.el5_4             rhel-x86_64-client-5            118 k

Transaction Summary
===================================================================================================
Install      0 Package(s)        
Update       2 Package(s)        
Remove       0 Package(s)        

Total size: 237 k
Is this ok [y/N]: y
Downloading Packages:
Running rpm_check_debug
ERROR with rpm_check_debug vs depsolve:
nspr is needed by (installed) nspr-devel-4.7.3-2.el5.i386
nspr is needed by (installed) nspr-devel-4.7.3-2.el5.i386
Complete!
(1, [u'Please report this error in http://yum.baseurl.org/report'])



 
> I have found the following nspr rpms on my system:
>
>  find /var/cache/yum -name "nspr*"

That lists what packages yum has cached data for, not what is installed
on your system.  "rpm -qa nspr\*" will list what nspr* RPMs you have
installed.

Hm, I get two nspr's.  See below:

> rpm -qa nspr\*
nspr-4.7.5-1.el5_4
nspr-devel-4.7.3-2.el5
nspr-4.7.5-1.el5_4

Thank you,
 
Mirko


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]