[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [rhelv5-list] Problems with X after 5.8 update



Anything in messages file right before you system went RO?

-----Original Message-----
From: rhelv5-list-bounces redhat com [mailto:rhelv5-list-bounces redhat com] On Behalf Of Ben
Sent: Tuesday, February 21, 2012 10:41 AM
To: RHEL5 mailing list
Subject: [rhelv5-list] Problems with X after 5.8 update

Note that I personally had a machine completely screw over its journal (went to a read-only filesystem) while doing the yum update to RHEL5.8 from 5.7. 
A few packages into the update (I think on glibc) the journal had an I/O issue.  Rather than try to remount it I tried to cleanly reboot it.  On reboot it needed a massive amount of fsck fixing (lots of things orphaned,
etc.) and then on the next reboot the box wasn't able to start X in runlevel
5:

init: Id "x" respawning too fast: disabled for 5 minutes

I tried downgrading the X stuff (Radeon driver) but nothing worked. 
However, once logged in in runlevel 3 I was able to issue "startx" and get something X-like running.  I have a dual-headed Radeon X300 card and the output is usually spanned with Xinerama.  Unless I completely removed the xorg.conf the monitors would go into powersave, or I'd only get a mirrored desktop.  After a few reboots and finally back into 2.6.18-274.18.1.el5PAE I was still getting the respawn error but was able to log in as me rather than root and startx with the old spanning desktop xorg.conf.  Right now every five minutes I get a respawn error in /var/log/messages, but at least I can work.  Even if I am not on the newest kernel.

Any thoughts?

Ben
--
Unix Support, MISD, University of Cambridge, England

_______________________________________________
rhelv5-list mailing list
rhelv5-list redhat com
https://www.redhat.com/mailman/listinfo/rhelv5-list




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]