[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: rpmlib(PayloadIsXz) <= 5.2-1 is needed by ?????



On Mon, 10 Aug 2009 14:03:55 -0700 (PDT), Antonio wrote:

> Thanks for trying to help me, but unfortunately the above does not work

You're not applying trouble-shooting skills.

> [root localhost Download]# rpm -Uvh rpm-4.7.1-1.fc11.i586.rpm 

You need to update _all_ rpm-* packages that are installed. RPM is
built as multiple packages, most important is "rpm-libs".
Run "rpm -qa rpm\*" then download all .fc11 builds for those packages
and rpm -Uvh them together with:

> error: Failed dependencies:
> 	liblzma.so.0 is needed by rpm-4.7.1-1.fc11.i586

This is found in  xz-libs-4.999.8-0.7.beta.fc11.i586  built from
package "xz".

> [root localhost Download]# rpm -Uvh rpm-4.7.1-1.fc11.i586.rpm --nodeps

Bzzz! Nobody recommended --nodeps, so don't decide to use it as long as
you ask for help. You still need to update rpm-libs, rpm-python.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]