[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Behavior differences between anaconda and "real" boot? (sata_nv problem)


I own a neat little AMD64 Shuttle SN85G4 (V1) which works great with FC3,
so I recommended buying the same to my dad. He bought the same, but it's V3
now, which apparently features a newer nForce3 250 chipset, and possibly
some other minor changes.
I only had an i386 FC3 install DVD handy when he got it, and with only a
modem connection, it really was my only option, so I installed that...
things went fine (except the Radeon 9200 through the DVI output, the
display went all black all the time after a few seconds, VGA works fine
My problem here is that it installed flawlessly on the Serial-ATA hard
drive attached to that nForce3 250 chipset (sata_nv module), but the
machine was never able to boot from the installed system.

I tried all that I could and came to these conclusions :
- It's not an IRQ problem (it shares IRQ11 with the firewire, but also does
at install time and I tried with another IRQ and firewire disabled, same
- It's not an ACPI or APIC issue (or at least isn't fixed by disabling

I actually really don't know what the problem can be. I tried with the
latest updated kernel, same thing. I also tried creating an initrd which
preloads all the same modules anaconda loads before loading sata_nv (usb,
firewire, scsi, forcedeth) in case the reverse engineered eth driver did
something weird that helped, or in case the delay in loading them gave
enough time to the drive to spin up or something, but no go.

Booting the install CD in rescue more _always_ works at getting the
Serial-ATA drive detected, whereas booting the installed system _never_
does (grub is there, and the initrd is loaded fine). The error on google
only shows LKML reports about problems with sata_via back in the 2.4 days.

The exact error is this :
ata1 is slow to respond, please be patient
ata1 failed to respond (30 secs)

All the kernel messages above (about detecting the chipset and both ata1
and ata2) are identical for the kernel used in anaconda and the one
installed. The kernel version, as well as the libata and sata_nv versions
reported are identical too...

So I was wondering what the issue could be. Some anaconda magic that the
installed system doesn't perform? Having an i686 kernel on that x86-64
machine and anaconda having yet another one?

For now I've put a good old parallel ATA drive, but still can't access the
Serial-ATA drive from that installed and booting system :-(


Clean custom Red Hat Linux rpm packages : http://freshrpms.net/
Fedora Core release 3 (Heidelberg) - Linux kernel 2.6.9-1.681_FC3.r300
Load : 0.13 0.21 0.45

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]