[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: hplip: hp-toolbox advertising?

On 3/28/07, Jesse Keating <jkeating redhat com> wrote:
On Wednesday 28 March 2007 16:20:24 Hans de Goede wrote:
> /me too,
> Can we please stop the HP bashing, they are doing a great job in providing
> support for their hardware, if their tools need better integration into the
> rest of Linux, then work with them, instead of bashing them / their
> software.

I'd wager their tools need to be better period.

I just unpacked a new HP photosmart C3180 multipurpose thingy.  I wanted to
print out my flight eticket.  After all this discussion I figured I'd give it
a try.  After powering on and attaching the printer via usb, I ask yum to
install hplip.  After downloading a 10+ megs of software, I had hplip on my
system.  I tried to <alt>-f2 and typed in hp-toolbox as that would be what
the menu called.  Nothing.  Tried again, nothing.  The hell?  Try it from a
console, HO!  A daemon isn't running and so the software just yells about not
being able to connect to "HPLIP I/O (hpiod)" whatever the hell that is.
Helpful.  Being a bit cluefull about these things, I guess it wants the hplip
service to be running.  So start the daemon, try again, and I get a big
screen about no installed HP devices found.  Ok, there is a setup device
button, click it, nothing detected.  Find Manually asks me for a cryptic USB
ID which it gives me no clue as how to find it.  Helpful.

So I give up on this, close it, stop the service.

I instead try System -> Administration -> Printing

New printer

Fill in details about name, description, location

Hit next and look at that, it automatically detected I had a USB printer
plugged in and even had the right name.  Forward again, pick the closest HP
driver from the list (HP Photosmart C3100) finalize and boom I can print a
test job, and furthermore print my etickets.

Yeah, this is great software allright.  *sigh*

Jesse Keating
Release Engineer: Fedora


If you had the hp daemons in, all you had to do was use CUPS to
install it. You don't need to use the HP toolkit at all .

Fedora Core 6 and proud

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]