[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

RPM database gone haywire. (FC2, x86_64, fully updated)



Hi, all. 

I screwed up, big time. I let a multi-RPM installation 
process go haywire (Labview, if y'all are curious), killed a process, 
and in so doing borked the RPM database as follows:

# rpm -q foo
dbiTagsInit: unrecognized tag name: "Pubkeys" ignored
rpmdb: Packages: unsupported hash version: 8
error: cannot open Packages index using db3 - Invalid argument (22)

I'd be much obliged for any info that woulr work in getting
this machine working again.

None of the tricks in http://www.rpm.org/hintskinks/repairdb/
seem to work:

# rpm --rebuilddb
dbiTagsInit: unrecognized tag name: "Pubkeys" ignored
rpmdb: Packages: unsupported hash version: 8
error: cannot open Packages index
#


# db_verify Packages
# rpm -q foo
dbiTagsInit: unrecognized tag name: "Pubkeys" ignored
rpmdb: Packages: unsupported hash version: 8
error: cannot open Packages index using db3 - Invalid argument (22)

# rpm --rebuilddb -vv
D: rebuilding database /var/lib/rpm into /var/lib/rpmrebuilddb.2824
D: creating directory /var/lib/rpmrebuilddb.2824
D: opening old database with dbapi 3
dbiTagsInit: unrecognized tag name: "Pubkeys" ignored
D: opening  db environment /var/lib/rpm/Packages create:cdb:mpool
D: opening  db index       /var/lib/rpm/Packages rdonly mode=0x0
rpmdb: Packages: unsupported hash version: 8
D: closed   db index       /var/lib/rpm/Packages
D: closed   db environment /var/lib/rpm/Packages
D: removed  db environment /var/lib/rpm/Packages
D: opening db file        /var/lib/rpm/packages.rpm mode 0x0
D: closed  db file        /var/lib/rpm/packages.rpm
error: cannot open Packages index
D: removing directory /var/lib/rpmrebuilddb.2824





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]