[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Setting default paper size in Gnome FC5

On Sun, 2006-05-07 at 15:24 +0100, Gavin Simpson wrote:
> On 5/7/06, Marc Schwartz <MSchwartz mn rr com> wrote:
> > Gavin,
> Thanks Marc
> > I have not seen anything definitive, however a Google search led me to a
> > SuSE list where the following thread may be of help:
> >
> > http://lists.suse.com/archive/suse-linux-e/2003-Jan/0343.html
> >
> > Thus, you may want to look at 'man lpoptions' to consider creating a
> > ~/.lpoptions file.
> Tried this out - I had an .lpoptions file on the problem desktop.

You might want to delete or rename this file to ascertain the
possibility that one or more local settings are causing a default
mis-configuration for your user profile. 

Also check /etc/cups/lpoptions to what is set for system level settings.

> Added media=A4. This didn't seem to do anything to help though - US
> Letter still default in evince. I didn't see anything related in
> bugzilla to do with printing or paper size. As this machine is in work
> and I'm at home just now, I've been running stuff via a SSH session
> with X forwarding. When testing if the .lpoptions addition worked, I
> tried to print a pdf in evince. As this was running from a shell I
> noticed the following messages:
> GnomePrintCupsPlugin-Message: The ppd file for the CUPS printer
> HPColourLaserJ could not be loaded.
> GnomePrintCupsPlugin-Message: The ppd file for the CUPS printer
> HPLaserJ could not be loaded.
> So may be this has something to do with it?

Perhaps. I am not sure what additional interactions might come into play
when using SSH. What conflicts might be present between your work
computer and your home computer in this modality.

I would first get your work computer running correctly (if possible)
before trying this over a SSH connection. Parsimony...  :-)

> > Not sure why this would be required, as gnome-print/CUPS aware
> > applications should be picking up the default configuration, unless they
> > have application specific settings, which Evo and Evince do not seem to
> > have from what I can tell.
> >
> > One other thing to consider would be to delete and re-define your
> > printers, in case something got messed up there.
> Given the above messages, I'll try this when in work on Monday.


> > Beyond this, I would have to defer to others relative to what might be
> > happening here, including the possibility of an FC5 bug of sorts. You
> > might want to do a search of bugzilla.redhat.com to see if perhaps
> > something has been posted there that might be relevant.

> Many thanks for your suggestions Marc. Much appreciated,

Happy to help. Hopefully it leads in the direction of resolution.



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]