[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Back at frustrating myself with clamav => clamd ??



On Sun, 2006-05-07 at 12:01 -0400, William Case wrote:
> Hi;
> 
> I can't get clamd to run.  I have been trying on and off for two weeks
> now.
> 
> freshclam works; clamscan works; and, clamdscan works.
> 
> service clamd start  does not work.
> 
> [root@ ~]# service clamd start
> clamd: unrecognized service
> 
> /etc/init.d/clamd (or any variation) does not exist.
> 
> /etc/init.d/clam-wrapper exits but doesn't seem to be used.
> 
> I have changed and played with the various options and defaults in
> clamd.conf so often that I have now changed everything back to default
> in order to start again.  I have used the clamav doc and man clamd.conf
> as reference; neither are very helpful in giving additional
> configuration information but are simply repetitive.
> 
> I have: /etc/clamd.conf soft linked to /etc/clamd.d/clamd.conf 
> 
> Dumb question.  What does <SERVICE> in clamd.conf mean?  Am I supposed
> to substitute something for it myself?  Isn't it defined in
> clamd-wrapper?
> 
> I am using FC5 with ClamAV 0.88.2 on a single user desktop.
> 
> Its a beautiful Sunday here; but I can't go out until this is solved.
> 
> Regards Bill

I use clamav 0.88.2 with the clamassassin script in /etc/procmailrc  to
invoke antivirus scanning of all mail. 

I start clamd via a simple startup script I setup myself in rc5.d :-

/etc/init.d/clamdset =

        #!/bin/sh
        #Clamd & freshclam
        
        /usr/local/sbin/clamd
        /usr/local/bin/freshclam -d -c 4
        


Hope that helps 

--Andrew Gray
Linnet Solutions Ltd


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]