[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: SAS on FC5



Yuandan Zhang wrote:
Hi, Has anyone sucessfully installed SAS 8.1 or SAS 9.1 on FC5? I have
difficulty to install SAS 8.1.
SAS 9.1 was installed.
The installation process was completed ok. When I run sas, I can't get
result or output but get these error messages at the command line.

Segmentation Violation In Task [ DATASTEP ]
Fault and traceback information not available
Task Traceback

Segmentation Violation In Task [ DATASTEP ]
Fault and traceback information not available
Task Traceback

The company support said

"I have checked our system requirements for Linux and unfortunately your
operating system is not compatible with SAS.

Software Requirements

Operating System

Red Hat Linux 7.1
Important: Most other distributions of Linux will not work.
SAS relies on the following operating system components:
?? Linux kernel 2.4.x
?? GNU libc 2.2.x (with LDT threads)
Installations that include different levels of the kernel and libc may be
compatible with SAS software,
but they have not been tested. "

I would not be surprised if the older version did not work, given the above requirements. I'd say that the company reply is spot on, at least with respect to 8.x versions.

If your SAS license is up to date via the annual fees, why are you still using (trying to use) an old and out of date version?

I would recommend that beyond the direct company support, which you are also paying for (presuming you are paying the annual fees), you might want to post to comp.soft-sys.sas, which is a SAS dedicated Usenet group. You will get a SAS focused audience there.

Alternatively, if you need a statistics environment that will run on FC consider R (it's in Extras):

  http://www.r-project.org/

which is FOSS. I have not used SAS in years, but do use R.

Good luck,

Marc Schwartz


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]