[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Issues w/ Gnome "lock screen" applet in FC5?



wwp wrote:
Hello Philip,


On Wed, 10 May 2006 23:28:00 -0600 Philip Prindeville <philipp_subx redfish-solutions com> wrote:

Is there an issue with the "Lock screen" applet thingie that
plugs into the upper panel?  I tried enabling it, and while
clicking on it brings up the screen saver, it doesn't seem to
lock the screen at all (not in a password-protected way).

I've checked "lock screen when screen saver is active".

Click "lock screen" on the applet's menu only brings up
the screen saver.

What am I missing?

Does `xscreensaver-command -lock` work (or gnome-screensaver-command)?


Regards,


Gnome-screensaver-command just puts the screen-saver up. It doesn't prompt for a
password.

Is there a problem running gnome as root????

On the other hand:

# xscreensaver-command --lock
xscreensaver-command: no screensaver is running on display :0.0

which is to be expected, since I didn't fire off the xscreensaver daemon.
But when I try to do that:

# xscreensaver &
[1] 2653
# Xlib: connection to ":0.0" refused by server
Xlib: No protocol specified

xscreensaver: Can't open display: :0.0
xscreensaver: initial effective uid/gid was root/root (0/0)
xscreensaver: running as nobody/nobody (99/99)

xscreensaver: This is probably because you're logging in as root.  You
             shouldn't log in as root: you should log in as a normal user,
             and then `su' as needed.  If you insist on logging in as
             root, you will have to turn off X's security features before
             xscreensaver will work.

             Please read the manual and FAQ for more information:

             http://www.jwz.org/xscreensaver/faq.html
             http://www.jwz.org/xscreensaver/man.html

So... what am I missing?

-Philip


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]