[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Delay when logginng in to FC5 via ssh



From a Windows PC I use an ssh client to log into my FC 5 box.

There is always a delay after the initial connection before being prompted for my password. The delay is around 15 seconds.

Once I'm logged in, there's no delay, command responses are quick.

The FC 5 box is 10.10.10.250, and th Windows PC is 10.10.10.24.

If I add 10.10.1.24 to /etc/hosts on FC5 then there is no delay when logging in.

So, I conclude that ssh is trying to determine the host name of the machine connecting to it, based on the connecting machine's IP address.

I don't think it's actualy ssh related because I experince a similar delay if I telnet to port 25 to my smtp server: If my 10.10.10.24 address is in /etc/hosts, the "220... reply banner" is displayed immediately, otherwise there is a long delay.

I have SELinux in permissive mode, so nothing magical should be blocked due to that.

The problem is, it is not practical to code all my private addresses in /etc/hosts. The network clients use dhcp so of course their addresses may change.

Can someone point me in the right direction of what to read up on... it's not an ssh problem, it's not a sendmail/smtp problem, it's somewhere lower than that... dns?

I'm certain that if I can solve the ssh-delay issue, that will also fix the telnet/smtp issue.

Thanks :-)



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]