[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Wierd dual booting problem with IDE drive and sata drive



Hello all,
im having a wierd problem here.i have 2 harddisks,one is a 20G maxtor IDE drive,another one is 250G seagate 7200.8 sata.i installed MS WindowsXP in the first parition of the sata drive and FC5 in the 1st parition of the IDE drive.(FC5 comes after XP). i installed grub in the IDE drive(hdd) as defualt,but with that grub i can only boot the FC5 but not Windows. It says "ntglr file missing" during booting of XP. Some guy in an internet forum told me that i need to install grub in the sata drive(sda),hence i did so(by using grub-install /dev/sda).after that i could boot XP using the new grub but the FC5 was no longer working.the error messgage is "selected partition cannot be mounted". my motherboard supports choosing the booting harddrive. so i switched the booting harddisk back to the ide drive(hdd) where FC5 exists,then the original grub shows up and FC works again but i cannot boot XP.
so in short,my situation is:
new grub in sda works with XP but not FC5,
old grub in hdd works with FC5 but not XP.
both grubs are from the FC5 installation cd,so i think they are the same version except the outlook.(im wandering why they look different).(but they share the same conf file in /boot/grub/grub.conf.am i right?)
can someone help?thx in advance.
regards
yufan


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]