[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Missing Dependency



Bob Fletcher wrote:
On Tue, 2006-05-30 at 01:24 -0400, Dan wrote:
Bob Fletcher wrote:
...
Error: Missing Dependency: geronimo-specs = 1.0-0.M2.2jpp_7fc is needed by package geronimo-specs-compat
Yum appears to be trying to update

geronimo-specs = 1.0-0.M2.2jpp_7fc

to

1.0-0.M2.3jpp

but, geronimo-specs-compat (that is installed) requires the old version, and does not appear to have a new version that will work with the new geronimo-specs. Try doing:
yum remove geronimo-specs-compat
and see if it has any dependencies to remove.
-Dan

Dan,
I tried your suggestion:

yum remove geronimo-specs-compat

gives the same dependency list (19 packages) as

yum remove geronimo-specs

except that the latter command also includes the package
geronimo-specs-compat; i.e. 20 packages.

Thanks,
Bob

As you said disabling JPackage solves the problem, it appears to be a JPackage problem; it's happened before. For now, you can either put enabled=0 in a line under the appropriate heading in /etc/yum.repos.d/jpackage.repo, or just exclude geronimo-specs and geronimo-specs-compat in /etc/yum.conf (for now): exclude=geronimo-specs*
-Dan


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]