[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Gdm won't start after updates on FC5



Problems today booting up FC5, after I did 873MB of updates on a fresh install 
of FC5. Thankfully I havn't done the latest updates for the other 2 FC5 
installs.

The updates installed ok, but at the end of installing them, there was a 
message about errors during the transaction (this was with apt, that I always 
use), but before I got around to sending this message to the list, I suffered 
a power outage. The machine booted up ok when the power came back on, but 
there seemed to be a bit more configuration being done during the bootup. 
Today when I booted up FC5, and there was nothing odd in the bootup text, but 
next I get a quick look at the init 3 login as usual, but after that, 
nothing, just a black screen. Mouse pointer moves ok, and has it's blue 
rotating halo showing that it's waiting for something to happen, and the 
first time I left it in that state for about 40mins, but nothing.

ctrl+alt+backspace exits the X server, and I get a bit of text on the screen, 
then X restarts, but still no Gdm. The 2 bits of output below might indicate 
something to someone.

This one is from /var/log/messages, and appears to be after I had run the 
ctrl+alt+backspace command.
Oct  1  12:00:36  localhost kernel:  ide0:  reset:  success
Oct   1  12:05:34 localhost  gdm[2259]:
gdm_slave_xioerror_handler:  Fatal  X  error - Restarting  :0

And this one is from /var/log/gdm, and there are 5 logs like this, all the 
same from today.

X Window System Version 7.0.0
Release Date: 21 December 2005
X Protocol Version 11, Revision 0, Release 7.0
Build Operating System:Linux 2.6.9-34.ELsmp i686Red Hat, Inc.
Current Operating System: Linux localhost.localdomain 2.6.15-1.2054_FC5 #1 Tue 
$
Build Date: 30 June 2006
        Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Sun Oct  1 11:33:24 2006
(==) Using config file: "/etc/X11/xorg.conf"
The XKEYBOARD keymap compiler (xkbcomp) reports:
> Warning:          Type "ONE_LEVEL" has 1 levels, but <RALT> has 2 symbols
>                   Ignoring extra symbols
Errors from xkbcomp are not fatal to the X server

I can bootup into init3 ok, and startX takes me directly into Gnome, which 
doesn't help much, as I use KDE.

Anyone have any suggestions as to what's gone wrong with Gdm since the 
updates?  Gdm is still installed, and verified by rpm -q -a gdm, and shows 
version -2.14.9-1

Nigel.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]