[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Make of PAM-PGSQL doesn't work



Patrick Nelson wrote:
Hello all,

I trying to build PAM-PgSQL (from https://sourceforge.net/projects/pam-pgsql) on an up to date FC5 system. This app has a dependency on 2 apps:

mhash-devel 0.9.1-0.fdr.1
postgresql-devel 8.1.4-1.fc5.1

which I have installed from RPMs with their parent apps (mhash and all postgresql-*) that I installed with yum.

It is a .bz tar file that you have to do a:

 ./configure
 make
 make install

The configure works fine but when I run make I get the following error:

 pam_get_service.c: In function 'pam_get_service'
pam_get_service.c10: error: 'NULL' undeclared (first use in this function) pam_get_service.c10: error: (Each undeclared identifier is reported only once
 pam_get_service.c10: error: for each function it appears in.)
 make: *** [pam_get_service.o] Error 1

Unfortunately I cant get much of a response from the developer, so I thought I would ask the smart people here. I'm not a big programmer here either but I can follow directions. Anyone know what I would have to do to get this working?

pnelson

OK I was looking at the use of NULL in all .c files in this app and I found that there was a header line missing from pam_get_service.c file:

#include <stdlib.h>

I put this in pam_get_service.c and did a 'make clean' and then the:

./configure
make

And now it built up without any errors.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]