[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Boot fails after change of motherboard (using LVM)





    Volker Englisch

mailto:Volker Englisch us    (h)


On 10/13/2006 04:01 AM Paul Howarth wrote:
On Thu, 2006-10-12 at 22:02 -0400, Volker Englisch wrote:
On 10/12/2006 12:14 PM Rob Andrews wrote:
You can get the same effect with the mkinitrd(8) tool.

mkinitrd /boot/initrd-<version> <version>

(where version is, for example, 2.6.18-1.2759.fc6)

This sounded like a great idea and I had hoped it to solve my problem. Unfortunately it didn't work and I am still getting the same error message after restarting the system
     Red Hat nash version 4.2.15 starting
      Reading all physical volumes. This may take a while ...
      No volume groups found
      Unable to find volume group "VolGroup00"

Is there anything else I could possibly try?

When the system boots, is it actually detecting the presence of the hard
disks?

Yes.

Can you tell which sata controller module is loaded when the rescue disk
is booted? (run lsmod and look for anything with sata in it)

It's sata_via.

Once you've found the sata modules in use, edit the /etc/modprobe.conf
of the installed system to ensure that it has a scsi_hostadapter line
for each sata module. For instance, I have:

alias scsi_hostadapter sata_sil24
alias scsi_hostadapter1 sata_nv

I have two identical SATA disks.  Would I need to enter
  alias scsi_hostadapter sata_via

to the modprobe.conf or
  alias scsi_hostadapter sata_via
  alias scsi_hostadapter1_sata_via

Volker


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]