[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Problems with iPod



ARRRGH!!!
OK, so the path export was good, it found libgpod-1.0, but then stumped out on

checking for PACKAGE... no
configure: error: *** No package 'libglade-2.0' found

acc'd to rpm -q I have libglade-0.17-16.2.1

Since that seems like a big jump from 0.17 to 2 I'm assuming this is
another path issue. Acc'd to locate I have

/usr/lib/libglade-2.0.so.0
/usr/lib/libglade-2.0.so.0.0.7

as well as 2 in my vmware stuff. How do I get gtkpod configure to
recognise that?

doing the Linux 2 step - 2 steps forward, one step back

ED


On 10/20/06, Todd Zullinger <tmz pobox com> wrote:
That's a bit confusing, but it doesn't mean libgpod-1.0 as you may be
led to believe.  It's a pkgconfig error, pkgconfig is looking for a
libgpod-1.0.pc file that will tell configure what flags to add to the
build process.  The trouble is that pkgconfig doesn't look in
/usr/local by default.  I forgot to mention that in my other mail.
You'll need to set the environmental variable PKG_CONFIG_PATH.  It
should be set to the location where libgpod-1.0.pc was installed,
which I believe will be /usr/local/lib/pkgconfig.  See man pkg-config.

    export PKG_CONFIG_PATH=/usr/local/lib/pkgconfig
    # build gtkpod
    ./configure && make && sudo make install

- --


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]