[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: yum update errors (upgrade from fc5->fc6)



I jut got mine working. (see thread: yum upgrade FX5->FC6 issues). Here is what I did:

BEFORE updating the fedora release I dud a yum -y update to insure everything was current. I then rebooted to the new kernel that was installed.

After that I updated the fedora release and for good measure the livna release too.

I was shown several file sets that had missing dependencies. At the recommendations of folks smarter than me, I "yum remove"ed them.

The upgrade is now running

-------- Original Message  --------
Subject: yum update errors (upgrade from fc5->fc6)
From: Pradeep Kilambi <pkilambi redhat com>
To: fedora-list redhat com
Date: 10/25/2006 02:04 PM

I'm trying to upgrade to fc6 from fc6. I installed the release rpms for fc6 and did a yum updtae and i get this error when processing deps:

--> Processing Dependency: libiso9660.so.4(ISO9660_4) for package: vcdimager
--> Processing Dependency: libttf.so.2 for package: VFlib2-xtools
--> Processing Dependency: liblzo.so.1 for package: mplayer
--> Processing Dependency: freetype = 2.1.10-5.2.1 for package: freetype-utils
--> Processing Conflict: hal conflicts kernel < 2.6.17
[<yum.packages.YumInstalledPackage instance at 0xb456e96c>]
Traceback (most recent call last):
 File "/usr/bin/yum", line 29, in ?
   yummain.main(sys.argv[1:])
 File "/usr/share/yum-cli/yummain.py", line 143, in main
   (result, resultmsgs) = base.buildTransaction()
File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 430, in buildTransaction
   (rescode, restring) = self.resolveDeps()
File "/usr/lib/python2.4/site-packages/yum/depsolve.py", line 239, in resolveDeps
   (checkdep, missing, conflict, errormsgs) = self._processConflict(dep)
File "/usr/lib/python2.4/site-packages/yum/depsolve.py", line 692, in _processConflict (confname, confarch, confepoch, confver, confrel) = conflict_packages[0] # take the first one, probably the only one
TypeError: unpack non-sequence

version of yum i'm running is:
$ rpm -q yum
yum-2.9.5-1

any idea whats up with this

--Prad

begin:vcard
fn:Paul Lemmons
n:Lemmons;Paul
org:Tucson Medical Center;Information Services
adr:;;5301 E. Grant Road;Tucson;AZ;85712;USA
email;internet:paul lemmons tmcaz com
title:Lead Systems Software Engineer
tel;work:520-324-1034
tel;fax:520-324-1206
tel;pager:paullem vtext com
tel;home:520-722-2642
tel;cell:520-603-7392
x-mozilla-html:TRUE
url:http://www.tmcaz.com
version:2.1
end:vcard

Attachment: smime.p7s
Description: S/MIME Cryptographic Signature


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]