[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Yum Dependency problem



david walcroft wrote:
> I'm trying to update but get this error
> 
> Total download size: 40 M
> Downloading Packages:
> Running rpm_check_debug
> ERROR with rpm_check_debug vs depsolve:
> Package python-reportlab needs python(abi) = 2.4, this is not available.
> Package metakit needs python(abi) = 2.4, this is not available.
> Package PyRTF needs python(abi) = 2.4, this is not available.
> Package python-sqlite2 needs python(abi) = 2.4, this is not available.
> Package python-imaging-tk needs python(abi) = 2.4, this is not available.
> Complete!
> 
> My rpm database says this
> 
> [david reddwarf ~]$ sudo rpm -q python
> python-2.5-12.fc7.i386
> 
> Why does yum want python-2.4 when 2.5 is installed.
> If it is required where do I find it?
> 
>  Thanks  david
> 
You have packages that have a dependency for a specific version of
Python. It happens to be an older version then what you have
installed. The packages may or may not work with the newer version.
The requirement for version 2.4 may be because the packager knows it
will not work with other versions, or because the packages made a
mistake when giving the requirements. (=2.4 instead of >=2.4)

You could use rpmfind.net to find a Fedora package of version 2.4,
or hope someone on the list can tell you where to find it. I am not
sure if you can have both versions installed at the same time, but
it wouldn't surprise me if you can. You may also want to check the
repos for a compat package of the older version.

Mikkel
-- 

  Do not meddle in the affairs of dragons,
for thou art crunchy and taste good with Ketchup!

Attachment: signature.asc
Description: OpenPGP digital signature


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]