[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Yum Dependency problem [Solved]



Michael Schwendt wrote:
On 02/11/2007, david walcroft <d_j_w46 bigpond net au> wrote:

Package python-reportlab needs python(abi) = 2.4, this is not
available.
Package metakit needs python(abi) = 2.4, this is not available.
Package PyRTF needs python(abi) = 2.4, this is not available.
Package python-sqlite2 needs python(abi) = 2.4, this is not available.
Package python-imaging-tk needs python(abi) = 2.4, this is not
available.

I have just done another  'yum update' for the third time today and yum
download 87 updates and cleaned up my dependency problem.
I notice that If I wait a couple of days dependency problems tend to
resolve them selves.

You are confused. There have not been any huge updates for this. For
example, "metakit" (see above quote) for stock Fedora 7 is unchanged
since May 23rd and does NOT require python(abi) = 2.4 (which is Fedora
Core 6 and older), but python(abi) = 2.5. A simple upgrade to Fedora 7
would have replaced it with the f7 package already. Same applies to
python-imaging-tk (... and I haven't checked the others).

$ rpm -qpR metakit-2.4.9.6-1.fc7.i386.rpm |grep py
python(abi) = 2.5

I had not been able to download for a week hence the 87 rpm's .
I did an upgrade install from FC6 > FC7 at the release of FC7.

david


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]