[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

FC8 repositor broken?



I haven't done an update in several days, so I started yum to check if upgrades were needed. I got a list and started the update, and was told gecko-libs was out of date, and is used by everything. Since it's not a package, I did this:

localhost:root> yum provides gecko-libs
Loading "refresh-updatesd" plugin
firefox.i386 : Mozilla Firefox Web browser.
firefox.i386 : Mozilla Firefox Web browser.
firefox.i386 : Mozilla Firefox Web browser.

localhost:root> yum upgrade firefox
Loading "refresh-updatesd" plugin
Setting up Upgrade Process
Resolving Dependencies
--> Running transaction check
--> Processing Dependency: gecko-libs = 1.8.1.8 for package: yelp
---> Package firefox.i386 0:2.0.0.9-1.fc8 set to be updated
--> Finished Dependency Resolution
Error: Missing Dependency: gecko-libs = 1.8.1.8 is needed by package yelp
localhost:root>

I always get a bad feeling when something is treated as if it were a package but isn't... so:

localhost:root> yum --enablerepo=updates-testing list '*gecko*'
Loading "refresh-updatesd" plugin
Available Packages
gecko-sharp2.i386 0.12-5.fc8 fedora gecko-sharp2-devel.i386 0.12-5.fc8 fedora
localhost:root>

No gecko-lib package, can't upgrade firefox which supposedly provides the libs, now what?

--
Bill Davidsen <davidsen tmr com>
  "We have more to fear from the bungling of the incompetent than from
the machinations of the wicked."  - from Slashdot


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]