[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

RE: VMware install on F7 -- Solved



On 08 November, 2007 09:48, Mark C. Allman wrote:

> 
> On Thu, 2007-11-08 at 09:40 -0500, McGuffey, David C. wrote:
> > 
> > ...During the install VMware complains that the kernel doesn't have
the
> > right modules. So it wants to compile them.  No problem, since I had
> > rtfm, I was ready...almost.  :(
> >
> > It is asking for the location of the linux source. The source
> > directories in /usr/src/redhat are empty...
> >
> Do you have the kernel development ("kernel-devel") package installed?
> That's what VMware needs.
> 
> Also, the source is looked for by VMware in /lib/modules/`uname
> -r`/source (or build instead of source, since they point to the same
> place), which is a link to /usr/src/kernels/`uname -r`.
> 
> -- Mark C, Allman, PMP
> 

That worked...problem solved

Output from the "any-any" version 114 script (which appeared to call the
vmware-install.pl script):

	Starting VMware services:
   	Virtual machine monitor                                 [  OK  ]
   	Blocking file system:                                   [  OK  ]
   	Virtual ethernet                                        [  OK  ]
   	Bridged networking on /dev/vmnet0                       [  OK  ]
   	Host network detection                                  [  OK  ]
   	Host-only networking on /dev/vmnet1 (background)        [  OK  ]
   	DHCP server on /dev/vmnet1                              [  OK  ]
   	Host-only networking on /dev/vmnet8 (background)        [  OK  ]
   	DHCP server on /dev/vmnet8                              [  OK  ]
   	NAT service on /dev/vmnet8                              [  OK  ]

	The configuration of VMware Workstation 6.0.2 build-59824 for 
	Linux for this running kernel completed successfully.

I'm not comfortable using an untrusted script out of the Czech Republic
for anything other than a toy machine.  It is fine for testing
virtualization in a lab, but at this point, not good for say doing my
taxes with TurboTax in WinXP on a home machine. If the script was signed
or provided an md5 hash, and VMware indicated that this was an
"approved" approach, then I might feel better.  But that is not the
case.

Anyone know the "pedigree" and quality of this any-any script?

I'm a bit dismayed that VMware is not playing a more active role in
making the scripts necessary to get their product to run on Fedora.
Afterall Fedora eventually rolls over into a Red Hat server offering.

Dave McGuffey
Principal Information System Security Engineer // NSA-IEM, NSA-IAM
SAIC, IISBU, Columbia, MD
 


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]