[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: java plugin



Le dimanche 11 novembre 2007 à 21:47 -0500, Tom Diehl a écrit :
> On Sun, 11 Nov 2007, Knute Johnson wrote:
> 
> >> I tried the icedtea plugin which seems to work fine except with the vpn
> >> software to connect to my university network. I will try it again
> >> another time but i need to install the sun java. How to do this ?
> >> Thanks
> >
> > Here's what I did on F8rc3 Live, it should work for you but please
> > post back if it doesn't.
> >
> > How to get Sun's Java running on F8rc3
> >
> > As root  -
> >
> > 1) Download the Sun Java Linux RPM from java.sun.com and install it.
> >
> > 2) Fix the Xinerama bug with
> >
> > 	sed -i 's/XINERAMA/FAKEEXTN/g'
> > /usr/java/jdk1.6.0_03//jre/lib/i386/xawt/libmawt.so
> >
> > 	Save a copy if you want to restore it to original.
> >
> > 3) Put the link to
> >
> > 	/usr/java/jdk1.6.0_03/jre/plugin/i386/ns7libjavaplugin_oji.so into
> >
> > 	/usr/lib/mozilla/plugins
> >
> > 4) Install compat-libstdc++-33
> >
> > 5) Remove nspluginwrapper
> >
> > Now you should be able to compile and run Java applications, run Java
> > Applets in Firefox and load and run Java Web Start programs.
> 
Thanks, here is what i did : 

1) Download the Sun Java Linux RPM from java.sun.com and install it.

2) Fix the Xinerama bug with 
sed -i
's/XINERAMA/FAKEEXTN/g' /usr/java/jdk1.6.0_03//jre/lib/i386/xawt/libmawt.so

3) yum install  java-1.6.0-sun-compat from jpackage non free

4) Remove /usr/java/jdk1.6.0_03/jre/plugin/i386/ns7libjavaplugin_oji.so
from /usr/lib/mozilla/plugins

5) Install compat-libstdc++-33

6) Remove nspluginwrapper

7) Use alternatives to point java to /usr/lib/jvm/jre-1.6.0-sun/bin/java
and libjavaplugin.so
to /usr/java/jdk1.6.0_03/jre/plugin/i386/ns7libjavaplugin_oji.so

All works and it seems to little more clean.

Eric


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]