[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Camera fc8 (canon ixus) weird usb problems



I had no problems with canon ixus 30 running fc6 and fc7

FC8, running root

Physically connect Canon Ixus 30
Camera import GUI pops up
Click Import Photos
Dialog: No camera detected
After a few sec's
Canon Digital Ixus 30 (normal mode)
Message: "Camera not ready, multiple 'Identify camera' requests failed: OS error in camera communication"


Searched the fedora forum, found following:
i too have this problem with a Canon A460 ... looks a recurrence of something previous I had in FC5

edit 50-udev.rules

find the lines as follws and change mode 0644 to 0666.

SUBSYSTEM=="usb", ACTION=="add", ENV{DEVTYPE}=="usb_device", \
NAME="bus/usb/$env{BUSNUM}/$env{DEVNUM}", MODE="0644"

ACTION=="add", SUBSYSTEM=="usb_device", \
PROGRAM="/bin/sh -c 'K=%k; K=$${K#usbdev}; printf bus/usb/%%03i/%%03i $${K%%%%.*} $${K#*.}'", \
NAME="%c", MODE="0644"

This is problably a kludge (I dont know for sure what impact this would have), but it lets my camera work for now.

I did not find a file 50-udev.rules. I found a file 50-udev-default.rules. I looked for the two places with 0644. I found only one.
Changed that, no effect.
But I do not know how this udev mechanism works, the editor left a backup of the original file, so maybe that is another problem.

Suggestions ?


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]