[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: yum problem after bad shutdown



On Friday 16 November 2007 02:28:05 Timothy Murphy wrote:
> Stefano Cavallari wrote:
> >> I've been unable to "yum update" my Fedora-7 laptop for a couple of
> >> days, because I apparently need a recent "kdebase3",
> >> which I cannot locate.
> >>
> >> ----------------------------------------
> >> [tim elizabeth ~]$ sudo
> >> yum --exclude=kdeartwork,kdebase-devel,kdebindings,kdeaddons update
> >> ...
> >> --> Finished Dependency Resolution
> >> Error: Missing Dependency: kdebase3 >= 3.5.8 is needed by package
> >> kdebindings
> >> Error: Missing Dependency: kdebase3 >= 3.5.8 is needed by package
> >> kdeaddons Error: Missing Dependency: kdebase-libs = 6:3.5.8-3.fc7 is
> >> needed by package kdebase-devel
> >> Error: Missing Dependency: kdebase3 >= 3.5.8 is needed by package
> >> kdeartwork [tim elizabeth ~]$ sudo
> >> yum --exclude=kdeartwork,kdebase-devel,kdebindings,kdeaddons update
> >> ----------------------------------------
> >>
> >> What happened was that my laptop ran out of battery
> >> in the middle of a yum update,
> >> and I assume that that was the cause of the trouble.
>
> ...
>
> > try
> > yum install yum-utils
> > package-cleanup --cleandupes
>
> I'm afraid this made things worse:
> -----------------------------------------
> Error: Missing Dependency: libkonq.so.4 is needed by package kdebase-devel
> Error: Missing Dependency: kdebase3 >= 3.5.8 is needed by package
> kdebindings
> Error: Missing Dependency: libkonq.so.4 is needed by package kdeaddons
> Error: Missing Dependency: libkdecorations.so.1 is needed by package
> kdebase-devel
> Error: Missing Dependency: libkonqsidebarplugin.so.1 is needed by package
> kdebase-devel
> Error: Missing Dependency: libkateinterfaces.so.0 is needed by package
> kdeaddons
> Error: Missing Dependency: libkhotkeys_shared.so.1 is needed by package
> kdebase-devel
> Error: Missing Dependency: libkateutils.so.0 is needed by package
> kdebase-devel
> Error: Missing Dependency: libkateinterfaces.so.0 is needed by package
> kdebase-devel
> Error: Missing Dependency: libkonqsidebarplugin.so.1 is needed by package
> kdeaddons
> Error: Missing Dependency: kdebase-libs = 6:3.5.8-3.fc7 is needed by
> package kdebase-devel
> Error: Missing Dependency: libkfontinst.so.0 is needed by package
> kdebase-devel
> Error: Missing Dependency: kdebase3 >= 3.5.8 is needed by package
> kdeartwork Error: Missing Dependency: libksgrd.so.1 is needed by package
> kdebase-devel Error: Missing Dependency: libtaskbar.so.1 is needed by
> package
> kdebase-devel
> Error: Missing Dependency: libksplashthemes.so.0 is needed by package
> kdebase-devel
> Error: Missing Dependency: kdebase3 >= 3.5.8 is needed by package kdeaddons
> Error: Missing Dependency: libkickermain.so.1 is needed by package
> kdebase-devel
> Error: Missing Dependency: libkdecorations.so.1 is needed by package
> kdeartwork
> Error: Missing Dependency: libkasbar.so.1 is needed by package
> kdebase-devel Error: Missing Dependency: libtaskmanager.so.1 is needed by
> package kdebase-devel
> -----------------------------------------
That it's not a bad thing, duplicate packages are not upgradeable and they 
hide other problems.
What repos do you use?
The output of package-cleanup --problems ? (it just list them) 
-- 


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]