[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Can Java just shoot me?



Chris G wrote:
On Sat, Nov 24, 2007 at 10:03:45PM -0500, Lamar Owen wrote:
We have found that the version number of the JRE has far more to do with whether Smiley (the name of the telescope) will run on a particular browser or not than the platform. We test many versions from 1.4.2 on up, and there are too many version-specific hacks to be at all funny.

I had this problem in reverse, we have an Oracle forms applet at work
and it insisted on having JRE version 1.4.2_06 and rejected any other
version.  I had to patch the applet to make it accept a later 1.4.2
version that it actually works with perfectly well.


So much for Java being 'platform independent'!  :-)

First, version dependence has nothing to do with platform independence, but if the applet worked with the check removed it wasn't a dependency at all - just a dumb applet checking something that wasn't necessary.

--
  Les Mikesell
   lesmikesell gmail com


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]