[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

fc8 no sound



I just installed fedora core 8, and after reboot I discovered I have no sound at all.
 
I get an error when I try:
aplay /usr/share/sounds/KDE_Startup_new.wav
 
*** PULSEAUDIO: Unable to connect: Connection refused
aplay: main:546: audio open error: Connection refused
 
After searching in google, I found a note that said I should do:
pulseaudio -vv
 
The results:
I: main.c: Found user 'pulse' (UID 499) and group 'pulse' (GID 496).
W: main.c: Warning: home directory of user 'pulse' is not '/var/run/pulse', ignoring.
I: main.c: Successfully dropped root privileges.
I: main.c: Page size is 4096 bytes
I: main.c: Fresh high-resolution timers available! Bon appetit!
D: cli-command.c: Checking for existance of '/usr/lib/pulse-0.9/modules//module-hal-detect.so': success
I: module-hal-detect.c: Trying capability alsa
D: module-hal-detect.c: Not loaded device /org/freedesktop/Hal/devices/computer_alsa_timer
D: module-hal-detect.c: Not loaded device /org/freedesktop/Hal/devices/computer_alsa_sequencer
D: module-hal-detect.c: Not loaded device /org/freedesktop/Hal/devices/pci_8086_2668_alsa_capture_2
D: module-hal-detect.c: Loading module-alsa-sink with arguments 'device=hw:0 sink_name=alsa_output.pci_8086_2668_alsa_playback_0'
ALSA lib pcm_hw.c:1207:(_snd_pcm_hw_open) Invalid value for card
E: module-alsa-sink.c: Error opening PCM device hw:0: No such device
E: module.c: Failed to load  module "module-alsa-sink" (argument: "device=hw:0 sink_name=alsa_output.pci_8086_2668_alsa_playback_0"): initialization failed.
D: module-hal-detect.c: Not loaded device /org/freedesktop/Hal/devices/pci_8086_2668_alsa_playback_0
D: module-hal-detect.c: Loading module-alsa-source with arguments 'device=hw:0 source_name=alsa_input.pci_8086_2668_alsa_capture_0'
ALSA lib pcm_hw.c:1207:(_snd_pcm_hw_open) Invalid value for card
E: module-alsa-source.c: Error opening PCM device hw:0: No such device
E: module.c: Failed to load  module "module-alsa-source" (argument: "device=hw:0 source_name=alsa_input.pci_8086_2668_alsa_capture_0"): initialization failed.
D: module-hal-detect.c: Not loaded device /org/freedesktop/Hal/devices/pci_8086_2668_alsa_capture_0
D: module-hal-detect.c: Not loaded device /org/freedesktop/Hal/devices/pci_8086_2668_alsa_hw_specific_2
D: module-hal-detect.c: Not loaded device /org/freedesktop/Hal/devices/pci_8086_2668_alsa_control__1
I: module-hal-detect.c: Loaded 0 modules.
I: module.c: Loaded "module-hal-detect" (index: #0; argument: "").
D: authkey.c: Got 0 bytes from cookie file '/var/run/pulse/.esd_auth', expected 16
I: module.c: Loaded "module-esound-protocol-unix" (index: #1; argument: "").
I: protocol-native.c: Allowing access to group 'pulse-access'.
D: authkey.c: Got 0 bytes from cookie file '/var/run/pulse/.pulse-cookie', expected 256
I: protocol-native.c: loading cookie from disk.
I: module.c: Loaded "module-native-protocol-unix" (index: #2; argument: "").
I: module-volume-restore.c: starting with empty ruleset.
I: module.c: Loaded "module-volume-restore" (index: #3; argument: "").
I: module.c: Loaded "module-default-device-restore" (index: #4; argument: "").
I: module.c: Loaded "module-rescue-streams" (index: #5; argument: "").
I: module.c: Loaded "module-suspend-on-idle" (index: #6; argument: "").
D: cli-command.c: Checking for existance of '/usr/lib/pulse-0.9/modules//module-x11-publish.so': success
D: module-x11-publish.c: using already loaded auth cookie.
E: x11wrap.c: XOpenDisplay() failed
E: module.c: Failed to load  module "module-x11-publish" (argument: ""): initialization failed.
E: main.c: Module load failed.
E: main.c: failed to initialize daemon.
I: module.c: Unloading "module-hal-detect" (index: #0).
D: module-hal-detect.c: dbus: interface=org.freedesktop.DBus, path=/org/freedesktop/DBus, member=NameAcquired
D: module-hal-detect.c: dbus: interface=org.freedesktop.DBus.Local, path=/org/freedesktop/DBus/Local, member=Disconnected
I: module.c: Unloaded "module-hal-detect" (index: #0).
I: module.c: Unloading "module-esound-protocol-unix" (index: #1).
I: module.c: Unloaded "module-esound-protocol-unix" (index: #1).
I: module.c: Unloading "module-native-protocol-unix" (index: #2).
I: module.c: Unloaded "module-native-protocol-unix" (index: #2).
I: module.c: Unloading "module-volume-restore" (index: #3).
I: module.c: Unloaded "module-volume-restore" (index: #3).
D: core-subscribe.c: dropped redundant event.
I: module.c: Unloading "module-default-device-restore" (index: #4).
I: module.c: Unloaded "module-default-device-restore" (index: #4).
D: core-subscribe.c: dropped redundant event.
I: module.c: Unloading "module-rescue-streams" (index: #5).
I: module.c: Unloaded "module-rescue-streams" (index: #5).
D: core-subscribe.c: dropped redundant event.
I: module.c: Unloading "module-suspend-on-idle" (index: #6).
I: module.c: Unloaded "module-suspend-on-idle" (index: #6).
D: core-subscribe.c: dropped redundant event.
I: main.c: Daemon terminated.
 
I did an lspci and got:
 
00:00.0 Host bridge: Intel Corporation 82915G/P/GV/GL/PL/910GL Memory Controller Hub (rev 04)
00:01.0 PCI bridge: Intel Corporation 82915G/P/GV/GL/PL/910GL PCI Express Root Port (rev 04)
00:1b.0 Audio device: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) High Definition Audio Controller (rev 03)
00:1c.0 PCI bridge: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) PCI Express Port 1 (rev 03)
00:1c.1 PCI bridge: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) PCI Express Port 2 (rev 03)
00:1c.2 PCI bridge: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) PCI Express Port 3 (rev 03)
00:1c.3 PCI bridge: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) PCI Express Port 4 (rev 03)
00:1d.0 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #1 (rev 03)
00:1d.1 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #2 (rev 03)
00:1d.2 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #3 (rev 03)
00:1d.3 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #4 (rev 03)
00:1d.7 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB2 EHCI Controller (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev d3)
00:1f.0 ISA bridge: Intel Corporation 82801FB/FR (ICH6/ICH6R) LPC Interface Bridge (rev 03)
00:1f.1 IDE interface: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) IDE Controller (rev 03)
00:1f.2 IDE interface: Intel Corporation 82801FB/FW (ICH6/ICH6W) SATA Controller (rev 03)
00:1f.3 SMBus: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) SMBus Controller (rev 03)
01:00.0 VGA compatible controller: ATI Technologies Inc RV380 0x3e50 [Radeon X600]
01:00.1 Display controller: ATI Technologies Inc RV380 [Radeon X600] (Secondary)
03:00.0 Ethernet controller: Marvell Technology Group Ltd. 88E8050 PCI-E ASF Gigabit Ethernet Controller (rev 17)
06:02.0 Communication controller: Conexant HSF 56k Data/Fax Modem
06:05.0 FireWire (IEEE 1394): Agere Systems FW323 (rev 61)
 
Any suggestions on how to get audio working would be appreciated.

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]