[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: wireless- networkmanager



Marcel Janssen wrote:
> On Sunday 25 November 2007, John Summerfield wrote:
>>> Could you be more specific as to what you are doing? I assume your start
>>> by left clicking on nm-applet icon. At what point are you entering your
>>> key?
>> and how often?
> 
> Well, one time should be enough but after trying 5 times I regard things to be 
> just not working properly.
> 
> Anyway, I tried several restarts of the network services and even two wireless 
> cards with different chipset. I always get prompted for the key no matter how 
> many times I enter it (and I'm sure the key is correct).

One of my pet peeves on my FC6 laptop.  Just for reference, it has
ipw3945 hardware, and I'm running the latest ipw3945-kmdls from
atrpms-testing on mine (because they work slightly better than what's in
atrpms-stable for me).  I'm also running the latest wpa_supplicant I can
find (atrpms too).  All the rest of my software is up-to-date with yum.
My WAP is a Linksys WRT54G, and I'm using WPA-PSK for security.

Here are my 3 scenarios:

1)  wireless comes up first time, all I need to do is enter the KeyRing
passphrase when I login.

2)  My wireless is not detected, in fact, NO wireless networks are
detected (there are at least 5 in my neighborhood).  I need to have
NetworkManager connect manually.  Sometime this works, sometimes this
doesn't.  In this case, my KeyRing passphrase is never queried, and I
get continually prompted.  This may sometimes succeed, but I haven't
figured out what's really going on here.  I usually get frustrated, turn
the laptop off, wait a few minutes and try again from a clean reboot.
Reloading wireless drivers may or may not fix this problem.  Its a
crapshoot, which makes me believe my problem may be hardware related.
I've never been able to use the iwconfig tools to create a connection
without using NM, and I stay away from trying to configure it with
system-config-network because I've never gotten that to work either.
ATM, to me, its black magic, and I hate that!

3)  My wireless gets dropped (often after being connect for a long
period of time).  The automatic re-connect gets hung and never connects
(its probably prompting me for my passphrase, but some FC6 bug keeps
this window under my other windows so I never notice it).  This happens
most often overnight and drops the connection in the very wee hours of
the morning.  I have no idea why.  Again, reloading the wireless drivers
may or may not work.  Maybe it depends on the phase of the moon?

Sometimes in the middle of 2), it magically prompts me for my KeyRing
passphrase (if its failed in 1 or 3) and then works.  Other times, I'm
in retry hell.  I wish NM would associate the passphrase with the
network name entered at the prompt and not just with the ESSID from the
network scan (and I can't even figure out how/when it does a network
re-scan! or even why it needs to scan again, or how it gets into modes
where its sees no networks!).

For the most part it works for me.  I've gotten into the habit of
leaving my laptop on 24/7 and only rebooting when:
	a)  I forget about the battery and it dies
	b)  I need to reboot because I lost the wireless.
	c)  I installed a new kernel and all of its kernel modules.

I'm hoping that iwl3945 is better when I have to upgrade to F8 or F9....

> regards,
> Marcel

-- 
Kevin J. Cummings
kjchome rcn com
cummings kjchome homeip net
cummings kjc386 framingham ma us
Registered Linux User #1232 (http://counter.li.org)


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]