[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Yet more yum help, please



"yum update" won't work for me on one computer
because it complains that up2date (an ancient package)
cannot be updated.

For some reason "yum --exclude=up2date* update"
does not seem to make any difference:
----------------------------
[root alfred tim]# yum --exclude=up2date* update
...
Running rpm_check_debug
ERROR with rpm_check_debug vs depsolve:
Package up2date needs python(abi) = 2.4, this is not available.
Complete!
----------------------------

There has been no mention of up2date in the transaction
except for this one.
So I don't understand why this package was mentioned at all.

I cannot remove it with "rpm -e":

----------------------------
[root alfred tim]# rpm -e -vv --nodeps up2date
...
+ /etc/rc.d/init.d/rhnsd stop
+ /sbin/chkconfig --del rhnsd
error reading information on service rhnsd: No such file or directory
D:     erase: waitpid(15510) rc 15510 status 100 secs 0.016
error: %preun(up2date-4.4.23-4.i386) scriptlet failed, exit status 1
----------------------------




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]