[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Yet more yum help, please



On 26/11/2007, Timothy Murphy <tim birdsnest maths tcd ie> wrote:
> "yum update" won't work for me on one computer
> because it complains that up2date (an ancient package)
> cannot be updated.
>
> For some reason "yum --exclude=up2date* update"
> does not seem to make any difference:

You cannot exclude old [already installed] packages when there is no
update for them. You can only exclude new packages found in the
repository.

> [root alfred tim]# yum --exclude=up2date* update
> ...
> Running rpm_check_debug
> ERROR with rpm_check_debug vs depsolve:
> Package up2date needs python(abi) = 2.4, this is not available.
> Complete!
> ----------------------------
>
> There has been no mention of up2date in the transaction
> except for this one.
> So I don't understand why this package was mentioned at all.

Because there is an upgrade to Python 2.5 taking away "python(abi) =
2.4" replacing it with "python(abi) = 2.5".

> I cannot remove it with "rpm -e":
>
> ----------------------------
> [root alfred tim]# rpm -e -vv --nodeps up2date

Add option --noscripts


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]