[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

FC6 to F7 yum update



Hi,

I'm attempting an upgrade to F7 from FC6.

I have updated the yum repo files to refer to the new repositories, but
issuing the following command produces the output shown:

# yum update yum
Loading "allowdowngrade" plugin
Loading "kmdl" plugin
Loading "downloadonly" plugin
Setting up repositories
...   <snip lots out output>
--> Running transaction check
Error: Missing Dependency: python(abi) = 2.4 is needed by package authconfig
Error: Unable to satisfy dependencies
Error: Package gnome-menus needs python-abi = 2.4, this is not available.
Error: Package subversion needs python(abi) = 2.4, this is not available.
Error: Package gnome-menus needs python(abi) = 2.4, this is not available.
Error: Package authconfig needs python(abi) = 2.4, this is not available.
Error: Package rpm-libs needs rpm = 4.4.2.1-2.fc6, this is not available.

As I understand it, F7 has python 2.5.  Is there any particular reason
why these listed packages aren't being upgraded along with python?

Other things I've done: I've disabled the updates repository and that makes things worse (more unavailable packages).

What are my options for solving this?

--
Graeme Hilton



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]