[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Sound permission problem



"Mikkel L. Ellertson" <mikkel infinity-ltd com> writes:

> Lars Bjørndal wrote:
>> lars bjorndal broadpark no (Lars Bjørndal) writes:
>> 
>>> Hi!
>>>
>>> I'm running Fedora F7, without X. I'm able to do 'mplayer <url>' for
>>> one user at a time. However, I'm not able to do 'mplayer <url>' for
>>> one user, and then 'mplayer <another-url>' as another user. Then I get
>>> the following error message:
>>>
>>> [AO_ALSA] alsa-lib: pcm_dmix.c:831:(snd_pcm_dmix_open) unable to
>>> create IPC semaphore
>>> [AO_ALSA] Playback open error: Permission denied
>>>
>>> It's not important to me to play mplayer that way, however, I want to
>>> be able to run speech-dispathcer (which, BTW should have an rpm pacage
>>> for Fedora) and play mplayer at the same time. How could I solve this
>>> permission problem?
>>>
>>> I've tried to put in /etc/security/console.perms.d/50-default.perms:
>>>
>>> <console>  0666 <sound>      0600 root,
>>>
>>> and ls -al /dev/audio gives:
>>>
>>> crw-rw-rw-+ 1 lrs root 14, 4 2007-11-29 10:00 /dev/audio
>>>
>>> Lars
>> 
> Dumb question - is the first user's mplayer closed before the second
> user tries to run their copy of mplayer? I am not familiar with the
> error message, but I am guessing that the problem is that something
> has a connection to the mixer open, and so you can not open another.
> If that is the case, you may be able to do something using the jack
> add-ons to alsa.

To your question: I tried to run two instances of mplayer at the same
time. And: I'm able to run two mplayer sessions at the same time from
the same user. The problem raises if I first start mplayer for user1,
then switches to user2 and start mplayer. Mplayer is still running on
user1. Any suggestions?

Lars


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]