[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: What happened to NFS on fedora 11?

On Wed, 07 Oct 2009 10:47:36 -0400
Tom Horsley wrote:

> On Wed, 7 Oct 2009 10:35:40 -0400
> Tom Horsley wrote:
> > Do I have to edit every NFS mount line in my
> > fstab manually?
> Apparently I do :-(. I can only mount from older machines
> if I explicitly give "proto=udp" as a mount option, at
> least none of the other work-arounds I've tried have worked.

I just discovered that I have the same problem here.  This computer is supposed
to mount two fileservers.  One of the fileservers runs Centos 5 and the other
is an Intel SS-4000E (a dedicated fileserver that runs its own embedded Linux).

The Centos 5 server mounted fine, but the Intel fileserver failed.

My fstab is set up as follows:

fileserver:/nas/NASDisk-00002/files/ /mnt/fileserver         nfs
defaults        0 0

After rebooting my computer last night when it finished updating to
nfs-utils-1.2.0-5.fc11.x86_64 the fileserver failed to mount.  I found out
about it this morning when my overnight backup to the fileserver failed to work.

Running the mount command from the commandline tells me this:

[root mutt frankcox]# mount fileserver:/nas/NASDisk-00002/files/ /mnt/fileserver

mount.nfs: requested NFS version or transport protocol is not supported

Using the suggested option "-o proto=udp", it mounted fine.

[root mutt frankcox]# mount -o proto=udp
fileserver:/nas/NASDisk-00002/files/ /mnt/fileserver

That worked and my Intel fileserver is now present on this computer again.

MELVILLE THEATRE ~ Melville Sask ~ http://www.melvilletheatre.com

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]