[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[RHSA-2011:1251-01] Important: JBoss Enterprise Portal Platform 5.1.1 update



-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

=====================================================================
                   Red Hat Security Advisory

Synopsis:          Important: JBoss Enterprise Portal Platform 5.1.1 update
Advisory ID:       RHSA-2011:1251-01
Product:           JBoss Enterprise Middleware
Advisory URL:      https://rhn.redhat.com/errata/RHSA-2011-1251.html
Issue date:        2011-09-04
CVE Names:         CVE-2011-1484 
=====================================================================

1. Summary:

JBoss Enterprise Portal Platform 5.1.1, which fixes one security issue and
various bugs, is now available from the Red Hat Customer Portal.

The Red Hat Security Response Team has rated this update as having
important security impact. A Common Vulnerability Scoring System (CVSS)
base score, which gives a detailed severity rating, is available from the
CVE link in the References section.

2. Description:

JBoss Enterprise Portal Platform is the open source implementation of the
Java EE suite of services and Portal services running atop JBoss Enterprise
Application Platform. It comprises a set of offerings for enterprise
customers who are looking for pre-configured profiles of JBoss Enterprise
Middleware components that have been tested and certified together to
provide an integrated experience.

This release of JBoss Enterprise Portal Platform 5.1.1 serves as a
replacement to JBoss Enterprise Portal Platform 5.1.0. It includes various
bug fixes which are detailed in the Release Notes. The Release Notes will
be available shortly from the link in the References section.

The following security issue is also fixed with this release:

It was found that JBoss Seam 2 did not properly block access to JBoss
Expression Language (EL) constructs in page exception handling, allowing
arbitrary Java methods to be executed. A remote attacker could use this
flaw to execute arbitrary code via a specially-crafted URL provided to
certain applications based on the JBoss Seam 2 framework. Note: A properly
configured and enabled Java Security Manager would prevent exploitation of
this flaw. (CVE-2011-1484)

If you have created custom applications that are packaged with a copy of
the JBoss Seam 2 library, those applications must be rebuilt with the
updated jboss-seam.jar file provided by this update.

Red Hat would like to thank Martin Kouba from IT SYSTEMS a.s. for reporting
CVE-2011-1484.

Warning: Before applying this update, back up all applications deployed on
JBoss Enterprise Portal Platform, along with all customized configuration
files.

All users of JBoss Enterprise Portal Platform 5.1.0 as provided from the
Red Hat Customer Portal are advised to upgrade to JBoss Enterprise Portal
Platform 5.1.1.

3. Solution:

The References section of this erratum contains a download link (you must
log in to download the update).

4. Bugs fixed (http://bugzilla.redhat.com/):

692421 - CVE-2011-1484 JBoss Seam privilege escalation caused by EL interpolation in FacesMessages

5. References:

https://www.redhat.com/security/data/cve/CVE-2011-1484.html
https://access.redhat.com/security/updates/classification/#important
https://docs.redhat.com/docs/en-US/JBoss_Enterprise_Portal_Platform/5.1/html/5.1.1_Release_Notes/index.html
https://access.redhat.com/jbossnetwork/restricted/listSoftware.html?product=jbportal&downloadType=distributions

6. Contact:

The Red Hat security contact is <secalert redhat com>.  More contact
details at https://access.redhat.com/security/team/contact/

Copyright 2011 Red Hat, Inc.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.4 (GNU/Linux)

iD8DBQFOZDjvXlSAg2UNWIIRArNkAJ4+K6stB5NK6l9VnpzDUaxq4T5TawCfcd5e
SsarcbodTBjeFtDDBDKhBgI=
=Wke7
-----END PGP SIGNATURE-----



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]