[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[RHSA-2017:2285-01] Moderate: authconfig security, bug fix, and enhancement update



-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

=====================================================================
                   Red Hat Security Advisory

Synopsis:          Moderate: authconfig security, bug fix, and enhancement update
Advisory ID:       RHSA-2017:2285-01
Product:           Red Hat Enterprise Linux
Advisory URL:      https://access.redhat.com/errata/RHSA-2017:2285
Issue date:        2017-08-01
CVE Names:         CVE-2017-7488 
=====================================================================

1. Summary:

An update for authconfig is now available for Red Hat Enterprise Linux 7.

Red Hat Product Security has rated this update as having a security impact
of Moderate. A Common Vulnerability Scoring System (CVSS) base score, which
gives a detailed severity rating, is available for each vulnerability from
the CVE link(s) in the References section.

2. Relevant releases/architectures:

Red Hat Enterprise Linux Client (v. 7) - x86_64
Red Hat Enterprise Linux ComputeNode (v. 7) - x86_64
Red Hat Enterprise Linux ComputeNode Optional (v. 7) - x86_64
Red Hat Enterprise Linux Server (v. 7) - aarch64, ppc64, ppc64le, s390x, x86_64
Red Hat Enterprise Linux Workstation (v. 7) - x86_64

3. Description:

The authconfig packages contain a command-line utility and a GUI
application that can configure a workstation to be a client for certain
network user information, authentication schemes, and other user
information and authentication-related options.

Security Fix(es):

* A flaw was found where authconfig could configure sssd in a way that
treats existing and non-existing logins differently, leaking information on
existence of a user. An attacker with physical or network access to the
machine could enumerate users via a timing attack. (CVE-2017-7488)

This issue was discovered by Tomas Mraz (Red Hat) and Thorsten Scherf (Red
Hat).

Additional Changes:

For detailed information on changes in this release, see the Red Hat
Enterprise Linux 7.4 Release Notes linked from the References section.

4. Solution:

For details on how to apply this update, which includes the changes
described in this advisory, refer to:

https://access.redhat.com/articles/11258

5. Bugs fixed (https://bugzilla.redhat.com/):

1329598 - authconfig breaks PAM system-auth-ac password-auth-ac for sssd in RHEL7.2
1378943 - [RFE] Allow authconfig to configure Smartcard authentication with SSSD
1441374 - gdm prompts for user password when smartcard login is configured and smartcard is inserted
1441604 - CVE-2017-7488 authconfig: Information leak when SSSD is used for authentication against remote server
1443949 - authconfig generates sssd.conf with --updateall --enablesssd --enablesssdauth
1449625 - Unlocalized strings and fuzzy translations in de, es, fr, it, ja, ko, pt_BR, ru, zh_CN, zh_TW
1450425 - After ipa-server-install cannot ssh to machine anymore.

6. Package List:

Red Hat Enterprise Linux Client (v. 7):

Source:
authconfig-6.2.8-30.el7.src.rpm

x86_64:
authconfig-6.2.8-30.el7.x86_64.rpm
authconfig-debuginfo-6.2.8-30.el7.x86_64.rpm
authconfig-gtk-6.2.8-30.el7.x86_64.rpm

Red Hat Enterprise Linux ComputeNode (v. 7):

Source:
authconfig-6.2.8-30.el7.src.rpm

x86_64:
authconfig-6.2.8-30.el7.x86_64.rpm
authconfig-debuginfo-6.2.8-30.el7.x86_64.rpm

Red Hat Enterprise Linux ComputeNode Optional (v. 7):

x86_64:
authconfig-debuginfo-6.2.8-30.el7.x86_64.rpm
authconfig-gtk-6.2.8-30.el7.x86_64.rpm

Red Hat Enterprise Linux Server (v. 7):

Source:
authconfig-6.2.8-30.el7.src.rpm

aarch64:
authconfig-6.2.8-30.el7.aarch64.rpm
authconfig-debuginfo-6.2.8-30.el7.aarch64.rpm
authconfig-gtk-6.2.8-30.el7.aarch64.rpm

ppc64:
authconfig-6.2.8-30.el7.ppc64.rpm
authconfig-debuginfo-6.2.8-30.el7.ppc64.rpm
authconfig-gtk-6.2.8-30.el7.ppc64.rpm

ppc64le:
authconfig-6.2.8-30.el7.ppc64le.rpm
authconfig-debuginfo-6.2.8-30.el7.ppc64le.rpm
authconfig-gtk-6.2.8-30.el7.ppc64le.rpm

s390x:
authconfig-6.2.8-30.el7.s390x.rpm
authconfig-debuginfo-6.2.8-30.el7.s390x.rpm
authconfig-gtk-6.2.8-30.el7.s390x.rpm

x86_64:
authconfig-6.2.8-30.el7.x86_64.rpm
authconfig-debuginfo-6.2.8-30.el7.x86_64.rpm
authconfig-gtk-6.2.8-30.el7.x86_64.rpm

Red Hat Enterprise Linux Workstation (v. 7):

Source:
authconfig-6.2.8-30.el7.src.rpm

x86_64:
authconfig-6.2.8-30.el7.x86_64.rpm
authconfig-debuginfo-6.2.8-30.el7.x86_64.rpm
authconfig-gtk-6.2.8-30.el7.x86_64.rpm

These packages are GPG signed by Red Hat for security.  Our key and
details on how to verify the signature are available from
https://access.redhat.com/security/team/key/

7. References:

https://access.redhat.com/security/cve/CVE-2017-7488
https://access.redhat.com/security/updates/classification/#moderate
https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Linux/7/html/7.4_Release_Notes/index.html

8. Contact:

The Red Hat security contact is <secalert redhat com>. More contact
details at https://access.redhat.com/security/team/contact/

Copyright 2017 Red Hat, Inc.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1

iD8DBQFZgC5hXlSAg2UNWIIRAonBAKCs4CjqMMIp4ZMcNY+wd72Ey4OL9gCfeDBN
XbqSb/TABXFXJCURIqZXN2o=
=h65c
-----END PGP SIGNATURE-----


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]