[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[RHSA-2017:1712-01] Important: Red Hat 3scale API Management Platform 2.0.0 security update



-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

=====================================================================
                   Red Hat Security Advisory

Synopsis:          Important: Red Hat 3scale API Management Platform 2.0.0 security update
Advisory ID:       RHSA-2017:1712-01
Product:           Red Hat 3scale API Management Platform
Advisory URL:      https://access.redhat.com/errata/RHSA-2017:1712
Issue date:        2017-07-06
CVE Names:         CVE-2017-1000364 CVE-2017-1000366 CVE-2017-7502 
                   CVE-2017-7512 
=====================================================================

1. Summary:

A security update for Red Hat 3scale API Management Platform 2.0.0 is now
available from the Red Hat Container Catalog.

Red Hat Product Security has rated this update as having a security impact
of Important. A Common Vulnerability Scoring System (CVSS) base score,
which gives a detailed severity rating, is available for each vulnerability
from the CVE link(s) in the References section.

2. Description:

Red Hat 3scale API Management Platform 2.0 is a platform for the management
of access and traffic for web-based APIs across a variety of deployment
options. 

Security Fix(es):

* It was found that RH-3scale AMP would permit creation of an access token
without a client secret. An attacker could use this flaw to circumvent
authentication controls and gain access to restricted APIs. (CVE-2017-7512)

The underlying container image was also rebuilt to resolve other security
issues. These were addressed via the following errata:
* https://access.redhat.com/errata/RHSA-2017:1365
* https://access.redhat.com/errata/RHSA-2017:1481
* https://access.redhat.com/errata/RHSA-2017:1484

Red Hat would like to thank Ryan Nauman (TruCode) for reporting the
CVE-2017-7512 issue.

3. Solution:

To apply this security fix, use the updated docker images.

4. Bugs fixed (https://bugzilla.redhat.com/):

1457997 - CVE-2017-7512 3scale AMP: validation bypass in oauth

5. References:

https://access.redhat.com/security/cve/CVE-2017-1000364
https://access.redhat.com/security/cve/CVE-2017-1000366
https://access.redhat.com/security/cve/CVE-2017-7502
https://access.redhat.com/security/cve/CVE-2017-7512
https://access.redhat.com/security/updates/classification/#important

6. Contact:

The Red Hat security contact is <secalert redhat com>. More contact
details at https://access.redhat.com/security/team/contact/

Copyright 2017 Red Hat, Inc.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1

iD8DBQFZXnRrXlSAg2UNWIIRAt8CAJ4z6GgABbXchEezh/jexuz0bTzY/gCbBwX7
C05p9KDlior7f7DTvXKIt4g=
=Iw0h
-----END PGP SIGNATURE-----


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]