[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[RHSA-2017:2698-01] Moderate: openvswitch security update



-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

=====================================================================
                   Red Hat Security Advisory

Synopsis:          Moderate: openvswitch security update
Advisory ID:       RHSA-2017:2698-01
Product:           Red Hat Enterprise Linux OpenStack Platform
Advisory URL:      https://access.redhat.com/errata/RHSA-2017:2698
Issue date:        2017-09-12
CVE Names:         CVE-2017-9214 CVE-2017-9263 CVE-2017-9265 
=====================================================================

1. Summary:

An update for openvswitch is now available for Red Hat Enterprise Linux
OpenStack Platform 7.0 (Kilo) for RHEL 7.

Red Hat Product Security has rated this update as having a security impact
of Moderate. A Common Vulnerability Scoring System (CVSS) base score, which
gives a detailed severity rating, is available for each vulnerability from
the CVE link(s) in the References section.

2. Relevant releases/architectures:

Red Hat Enterprise Linux OpenStack Platform 7.0 (Kilo) for RHEL 7 - noarch, x86_64

3. Description:

Open vSwitch provides standard network bridging functions and support for
the OpenFlow protocol for remote per-flow control of traffic.

Security Fix(es):

* An unsigned integer wrap around that led to a buffer over-read was found
when parsing OFPT_QUEUE_GET_CONFIG_REPLY messages in Open vSwitch (OvS). An
attacker could use this issue to cause a remote denial of service attack.
(CVE-2017-9214)

* While parsing an OpenFlow role status message Open vSwitch (OvS), a call
to the abort() function for undefined role status reasons in the function
'ofp_print_role_status_message' in 'lib/ofp-print.c' could be misused for a
remote denial of service attack by a malicious switch. (CVE-2017-9263)

* A buffer over-read issue was found in Open vSwitch (OvS) which emerged
while parsing the GroupMod OpenFlow messages sent from the controller. The
issue could enable an attacker to cause a denial of service type of attack.
(CVE-2017-9265)

4. Solution:

For details on how to apply this update, which includes the changes
described in this advisory, refer to:

https://access.redhat.com/articles/11258

5. Bugs fixed (https://bugzilla.redhat.com/):

1431497 - openvswitch: /var/log/openvswitch is world readable
1456795 - CVE-2017-9214 openvswitch: Integer underflow in the ofputil_pull_queue_get_config_reply10 function
1457327 - CVE-2017-9263 openvswitch: Invalid processing of a malicious OpenFlow role status message
1457335 - CVE-2017-9265 openvswitch: Buffer over-read while parsing the group mod OpenFlow message

6. Package List:

Red Hat Enterprise Linux OpenStack Platform 7.0 (Kilo) for RHEL 7:

Source:
openvswitch-2.5.0-15.git20160727.el7ost.src.rpm

noarch:
python-openvswitch-2.5.0-15.git20160727.el7ost.noarch.rpm

x86_64:
openvswitch-2.5.0-15.git20160727.el7ost.x86_64.rpm
openvswitch-debuginfo-2.5.0-15.git20160727.el7ost.x86_64.rpm

These packages are GPG signed by Red Hat for security.  Our key and
details on how to verify the signature are available from
https://access.redhat.com/security/team/key/

7. References:

https://access.redhat.com/security/cve/CVE-2017-9214
https://access.redhat.com/security/cve/CVE-2017-9263
https://access.redhat.com/security/cve/CVE-2017-9265
https://access.redhat.com/security/updates/classification/#moderate

8. Contact:

The Red Hat security contact is <secalert redhat com>. More contact
details at https://access.redhat.com/security/team/contact/

Copyright 2017 Red Hat, Inc.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1

iD8DBQFZuBfhXlSAg2UNWIIRAucYAKC2OTqR8L0zhGVu6Fjje7Cy8bbkDQCeMy3j
oK3AV3667tXLHxFfP7qN0Iw=
=TCdS
-----END PGP SIGNATURE-----


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]