[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[RHSA-2019:2126-01] Low: libwpd security update



-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

=====================================================================
                   Red Hat Security Advisory

Synopsis:          Low: libwpd security update
Advisory ID:       RHSA-2019:2126-01
Product:           Red Hat Enterprise Linux
Advisory URL:      https://access.redhat.com/errata/RHSA-2019:2126
Issue date:        2019-08-06
CVE Names:         CVE-2018-19208 
=====================================================================

1. Summary:

An update for libwpd is now available for Red Hat Enterprise Linux 7.

Red Hat Product Security has rated this update as having a security impact
of Low. A Common Vulnerability Scoring System (CVSS) base score, which
gives a detailed severity rating, is available for each vulnerability from
the CVE link(s) in the References section.

2. Relevant releases/architectures:

Red Hat Enterprise Linux Client (v. 7) - x86_64
Red Hat Enterprise Linux Client Optional (v. 7) - noarch, x86_64
Red Hat Enterprise Linux ComputeNode Optional (v. 7) - noarch, x86_64
Red Hat Enterprise Linux Server (v. 7) - ppc64le, x86_64
Red Hat Enterprise Linux Server Optional (v. 7) - noarch, ppc64, ppc64le, s390x, x86_64
Red Hat Enterprise Linux Workstation (v. 7) - x86_64
Red Hat Enterprise Linux Workstation Optional (v. 7) - noarch, x86_64

3. Description:

libwpd is a library for reading and converting Corel WordPerfect Office
documents.

Security Fix(es):

* libwpd: NULL pointer dereference in the function
WP6ContentListener::defineTable in WP6ContentListener.cpp (CVE-2018-19208)

For more details about the security issue(s), including the impact, a CVSS
score, acknowledgments, and other related information, refer to the CVE
page(s) listed in the References section.

Additional Changes:

For detailed information on changes in this release, see the Red Hat
Enterprise Linux 7.7 Release Notes linked from the References section.

4. Solution:

For details on how to apply this update, which includes the changes
described in this advisory, refer to:

https://access.redhat.com/articles/11258

5. Bugs fixed (https://bugzilla.redhat.com/):

1649414 - CVE-2018-19208 libwpd: NULL pointer dereference in the function WP6ContentListener::defineTable in WP6ContentListener.cpp

6. Package List:

Red Hat Enterprise Linux Client (v. 7):

Source:
libwpd-0.10.0-2.el7.src.rpm

x86_64:
libwpd-0.10.0-2.el7.i686.rpm
libwpd-0.10.0-2.el7.x86_64.rpm
libwpd-debuginfo-0.10.0-2.el7.i686.rpm
libwpd-debuginfo-0.10.0-2.el7.x86_64.rpm

Red Hat Enterprise Linux Client Optional (v. 7):

noarch:
libwpd-doc-0.10.0-2.el7.noarch.rpm

x86_64:
libwpd-debuginfo-0.10.0-2.el7.i686.rpm
libwpd-debuginfo-0.10.0-2.el7.x86_64.rpm
libwpd-devel-0.10.0-2.el7.i686.rpm
libwpd-devel-0.10.0-2.el7.x86_64.rpm
libwpd-tools-0.10.0-2.el7.x86_64.rpm

Red Hat Enterprise Linux ComputeNode Optional (v. 7):

Source:
libwpd-0.10.0-2.el7.src.rpm

noarch:
libwpd-doc-0.10.0-2.el7.noarch.rpm

x86_64:
libwpd-0.10.0-2.el7.i686.rpm
libwpd-0.10.0-2.el7.x86_64.rpm
libwpd-debuginfo-0.10.0-2.el7.i686.rpm
libwpd-debuginfo-0.10.0-2.el7.x86_64.rpm
libwpd-devel-0.10.0-2.el7.i686.rpm
libwpd-devel-0.10.0-2.el7.x86_64.rpm
libwpd-tools-0.10.0-2.el7.x86_64.rpm

Red Hat Enterprise Linux Server (v. 7):

Source:
libwpd-0.10.0-2.el7.src.rpm

ppc64le:
libwpd-0.10.0-2.el7.ppc64le.rpm
libwpd-debuginfo-0.10.0-2.el7.ppc64le.rpm

x86_64:
libwpd-0.10.0-2.el7.i686.rpm
libwpd-0.10.0-2.el7.x86_64.rpm
libwpd-debuginfo-0.10.0-2.el7.i686.rpm
libwpd-debuginfo-0.10.0-2.el7.x86_64.rpm

Red Hat Enterprise Linux Server Optional (v. 7):

Source:
libwpd-0.10.0-2.el7.src.rpm

noarch:
libwpd-doc-0.10.0-2.el7.noarch.rpm

ppc64:
libwpd-0.10.0-2.el7.ppc.rpm
libwpd-0.10.0-2.el7.ppc64.rpm
libwpd-debuginfo-0.10.0-2.el7.ppc.rpm
libwpd-debuginfo-0.10.0-2.el7.ppc64.rpm
libwpd-devel-0.10.0-2.el7.ppc.rpm
libwpd-devel-0.10.0-2.el7.ppc64.rpm
libwpd-tools-0.10.0-2.el7.ppc64.rpm

ppc64le:
libwpd-debuginfo-0.10.0-2.el7.ppc64le.rpm
libwpd-devel-0.10.0-2.el7.ppc64le.rpm
libwpd-tools-0.10.0-2.el7.ppc64le.rpm

s390x:
libwpd-0.10.0-2.el7.s390.rpm
libwpd-0.10.0-2.el7.s390x.rpm
libwpd-debuginfo-0.10.0-2.el7.s390.rpm
libwpd-debuginfo-0.10.0-2.el7.s390x.rpm
libwpd-devel-0.10.0-2.el7.s390.rpm
libwpd-devel-0.10.0-2.el7.s390x.rpm
libwpd-tools-0.10.0-2.el7.s390x.rpm

x86_64:
libwpd-debuginfo-0.10.0-2.el7.i686.rpm
libwpd-debuginfo-0.10.0-2.el7.x86_64.rpm
libwpd-devel-0.10.0-2.el7.i686.rpm
libwpd-devel-0.10.0-2.el7.x86_64.rpm
libwpd-tools-0.10.0-2.el7.x86_64.rpm

Red Hat Enterprise Linux Workstation (v. 7):

Source:
libwpd-0.10.0-2.el7.src.rpm

x86_64:
libwpd-0.10.0-2.el7.i686.rpm
libwpd-0.10.0-2.el7.x86_64.rpm
libwpd-debuginfo-0.10.0-2.el7.i686.rpm
libwpd-debuginfo-0.10.0-2.el7.x86_64.rpm

Red Hat Enterprise Linux Workstation Optional (v. 7):

noarch:
libwpd-doc-0.10.0-2.el7.noarch.rpm

x86_64:
libwpd-debuginfo-0.10.0-2.el7.i686.rpm
libwpd-debuginfo-0.10.0-2.el7.x86_64.rpm
libwpd-devel-0.10.0-2.el7.i686.rpm
libwpd-devel-0.10.0-2.el7.x86_64.rpm
libwpd-tools-0.10.0-2.el7.x86_64.rpm

These packages are GPG signed by Red Hat for security.  Our key and
details on how to verify the signature are available from
https://access.redhat.com/security/team/key/

7. References:

https://access.redhat.com/security/cve/CVE-2018-19208
https://access.redhat.com/security/updates/classification/#low
https://access.redhat.com/documentation/en-us/red_hat_enterprise_linux/7/html/7.7_release_notes/index

8. Contact:

The Red Hat security contact is <secalert redhat com>. More contact
details at https://access.redhat.com/security/team/contact/

Copyright 2019 Red Hat, Inc.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1

iQIVAwUBXUl3sdzjgjWX9erEAQhjAA/7Blz8nXKXqu2QLL9oofyRQri+yIITzsU6
ZOkgaYemZ0hCRmiAafRH28xwyxe7W89gso3crNh5d46e6Jb3xAJrhmYd7rJJpWST
k/ym7+t+1cWJdfDlaZ4i/uCwqbfdhrmrjutJCJr8qT9MfPGm3OJy0BNGojnv7IoW
3P7Y3CgeE6GzwxST4gNom1kqeNa64MWA1+pqPqTcuP9NZdw1p7baYwvLmMxNVCCL
nYWQwkeFI0IjdL0hmecxEMfErts5XWtrbBVFJhHPJfLbP1UIFpxX5TF6rgJtZFG3
awAEpxtpD3Mh8NxFa6GO1u0Fv3oo97UIsm9ShMoBkAXO8CCALf7d57EMSviiXgwY
YcJNijobXx2/ct9AUeAfM3Qp0jrt4y/7ZBszfCJn+9Y71v8DArRRIPfvmfrO0Zmd
Wlt6zzyn5uufYDDBxFwTB7CmPu8qMaDBvSpNQEIxkpHGUW/BblCwM+sNaQl/Bn90
0/mViscnRAhC1wRkunQorM96VQDTFQqs+7ILUZ3mDKw3pqL7M+2mMCwFDtJpof7p
i6RK3XxKVcWRlNrX5CSJ2xYcA74kFSHpCj7FOgVZcdZidHJ1h2NbF7quoqO7fuLW
f7Q8MPEslZ6dRizhvWhw2uLmLXnff3XpH5vErfts3Cv/W76H3VSXJlmeDK51C8t5
iRQ1+Dyonvc=
=QnFJ
-----END PGP SIGNATURE-----


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]