[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[RHSA-2019:1942-01] Important: perl security update



-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

=====================================================================
                   Red Hat Security Advisory

Synopsis:          Important: perl security update
Advisory ID:       RHSA-2019:1942-01
Product:           Red Hat Enterprise Linux
Advisory URL:      https://access.redhat.com/errata/RHSA-2019:1942
Issue date:        2019-07-30
CVE Names:         CVE-2018-18311 
=====================================================================

1. Summary:

An update for perl is now available for Red Hat Enterprise Linux 7.4
Extended Update Support.

Red Hat Product Security has rated this update as having a security impact
of Important. A Common Vulnerability Scoring System (CVSS) base score,
which gives a detailed severity rating, is available for each vulnerability
from the CVE link(s) in the References section.

2. Relevant releases/architectures:

Red Hat Enterprise Linux ComputeNode EUS (v. 7.4) - noarch, x86_64
Red Hat Enterprise Linux ComputeNode Optional EUS (v. 7.4) - x86_64
Red Hat Enterprise Linux Server EUS (v. 7.4) - noarch, ppc64, ppc64le, s390x, x86_64
Red Hat Enterprise Linux Server Optional EUS (v. 7.4) - ppc64, ppc64le, s390x, x86_64

3. Description:

Perl is a high-level programming language that is commonly used for system
administration utilities and web programming.

Security Fix(es):

* perl: Integer overflow leading to buffer overflow in Perl_my_setenv()
(CVE-2018-18311)

For more details about the security issue(s), including the impact, a CVSS
score, acknowledgments, and other related information, refer to the CVE
page(s) listed in the References section.

4. Solution:

For details on how to apply this update, which includes the changes
described in this advisory, refer to:

https://access.redhat.com/articles/11258

5. Bugs fixed (https://bugzilla.redhat.com/):

1646730 - CVE-2018-18311 perl: Integer overflow leading to buffer overflow in Perl_my_setenv()

6. Package List:

Red Hat Enterprise Linux ComputeNode EUS (v. 7.4):

Source:
perl-5.16.3-292.el7_4.1.src.rpm

noarch:
perl-CPAN-1.9800-292.el7_4.1.noarch.rpm
perl-ExtUtils-CBuilder-0.28.2.6-292.el7_4.1.noarch.rpm
perl-ExtUtils-Embed-1.30-292.el7_4.1.noarch.rpm
perl-ExtUtils-Install-1.58-292.el7_4.1.noarch.rpm
perl-IO-Zlib-1.10-292.el7_4.1.noarch.rpm
perl-Locale-Maketext-Simple-0.21-292.el7_4.1.noarch.rpm
perl-Module-CoreList-2.76.02-292.el7_4.1.noarch.rpm
perl-Module-Loaded-0.08-292.el7_4.1.noarch.rpm
perl-Object-Accessor-0.42-292.el7_4.1.noarch.rpm
perl-Package-Constants-0.02-292.el7_4.1.noarch.rpm
perl-Pod-Escapes-1.04-292.el7_4.1.noarch.rpm

x86_64:
perl-5.16.3-292.el7_4.1.x86_64.rpm
perl-Time-Piece-1.20.1-292.el7_4.1.x86_64.rpm
perl-core-5.16.3-292.el7_4.1.x86_64.rpm
perl-debuginfo-5.16.3-292.el7_4.1.i686.rpm
perl-debuginfo-5.16.3-292.el7_4.1.x86_64.rpm
perl-devel-5.16.3-292.el7_4.1.i686.rpm
perl-devel-5.16.3-292.el7_4.1.x86_64.rpm
perl-libs-5.16.3-292.el7_4.1.i686.rpm
perl-libs-5.16.3-292.el7_4.1.x86_64.rpm
perl-macros-5.16.3-292.el7_4.1.x86_64.rpm

Red Hat Enterprise Linux ComputeNode Optional EUS (v. 7.4):

x86_64:
perl-debuginfo-5.16.3-292.el7_4.1.x86_64.rpm
perl-tests-5.16.3-292.el7_4.1.x86_64.rpm

Red Hat Enterprise Linux Server EUS (v. 7.4):

Source:
perl-5.16.3-292.el7_4.1.src.rpm

noarch:
perl-CPAN-1.9800-292.el7_4.1.noarch.rpm
perl-ExtUtils-CBuilder-0.28.2.6-292.el7_4.1.noarch.rpm
perl-ExtUtils-Embed-1.30-292.el7_4.1.noarch.rpm
perl-ExtUtils-Install-1.58-292.el7_4.1.noarch.rpm
perl-IO-Zlib-1.10-292.el7_4.1.noarch.rpm
perl-Locale-Maketext-Simple-0.21-292.el7_4.1.noarch.rpm
perl-Module-CoreList-2.76.02-292.el7_4.1.noarch.rpm
perl-Module-Loaded-0.08-292.el7_4.1.noarch.rpm
perl-Object-Accessor-0.42-292.el7_4.1.noarch.rpm
perl-Package-Constants-0.02-292.el7_4.1.noarch.rpm
perl-Pod-Escapes-1.04-292.el7_4.1.noarch.rpm

ppc64:
perl-5.16.3-292.el7_4.1.ppc64.rpm
perl-Time-Piece-1.20.1-292.el7_4.1.ppc64.rpm
perl-core-5.16.3-292.el7_4.1.ppc64.rpm
perl-debuginfo-5.16.3-292.el7_4.1.ppc.rpm
perl-debuginfo-5.16.3-292.el7_4.1.ppc64.rpm
perl-devel-5.16.3-292.el7_4.1.ppc.rpm
perl-devel-5.16.3-292.el7_4.1.ppc64.rpm
perl-libs-5.16.3-292.el7_4.1.ppc.rpm
perl-libs-5.16.3-292.el7_4.1.ppc64.rpm
perl-macros-5.16.3-292.el7_4.1.ppc64.rpm

ppc64le:
perl-5.16.3-292.el7_4.1.ppc64le.rpm
perl-Time-Piece-1.20.1-292.el7_4.1.ppc64le.rpm
perl-core-5.16.3-292.el7_4.1.ppc64le.rpm
perl-debuginfo-5.16.3-292.el7_4.1.ppc64le.rpm
perl-devel-5.16.3-292.el7_4.1.ppc64le.rpm
perl-libs-5.16.3-292.el7_4.1.ppc64le.rpm
perl-macros-5.16.3-292.el7_4.1.ppc64le.rpm

s390x:
perl-5.16.3-292.el7_4.1.s390x.rpm
perl-Time-Piece-1.20.1-292.el7_4.1.s390x.rpm
perl-core-5.16.3-292.el7_4.1.s390x.rpm
perl-debuginfo-5.16.3-292.el7_4.1.s390.rpm
perl-debuginfo-5.16.3-292.el7_4.1.s390x.rpm
perl-devel-5.16.3-292.el7_4.1.s390.rpm
perl-devel-5.16.3-292.el7_4.1.s390x.rpm
perl-libs-5.16.3-292.el7_4.1.s390.rpm
perl-libs-5.16.3-292.el7_4.1.s390x.rpm
perl-macros-5.16.3-292.el7_4.1.s390x.rpm

x86_64:
perl-5.16.3-292.el7_4.1.x86_64.rpm
perl-Time-Piece-1.20.1-292.el7_4.1.x86_64.rpm
perl-core-5.16.3-292.el7_4.1.x86_64.rpm
perl-debuginfo-5.16.3-292.el7_4.1.i686.rpm
perl-debuginfo-5.16.3-292.el7_4.1.x86_64.rpm
perl-devel-5.16.3-292.el7_4.1.i686.rpm
perl-devel-5.16.3-292.el7_4.1.x86_64.rpm
perl-libs-5.16.3-292.el7_4.1.i686.rpm
perl-libs-5.16.3-292.el7_4.1.x86_64.rpm
perl-macros-5.16.3-292.el7_4.1.x86_64.rpm

Red Hat Enterprise Linux Server Optional EUS (v. 7.4):

ppc64:
perl-debuginfo-5.16.3-292.el7_4.1.ppc64.rpm
perl-tests-5.16.3-292.el7_4.1.ppc64.rpm

ppc64le:
perl-debuginfo-5.16.3-292.el7_4.1.ppc64le.rpm
perl-tests-5.16.3-292.el7_4.1.ppc64le.rpm

s390x:
perl-debuginfo-5.16.3-292.el7_4.1.s390x.rpm
perl-tests-5.16.3-292.el7_4.1.s390x.rpm

x86_64:
perl-debuginfo-5.16.3-292.el7_4.1.x86_64.rpm
perl-tests-5.16.3-292.el7_4.1.x86_64.rpm

These packages are GPG signed by Red Hat for security.  Our key and
details on how to verify the signature are available from
https://access.redhat.com/security/team/key/

7. References:

https://access.redhat.com/security/cve/CVE-2018-18311
https://access.redhat.com/security/updates/classification/#important

8. Contact:

The Red Hat security contact is <secalert redhat com>. More contact
details at https://access.redhat.com/security/team/contact/

Copyright 2019 Red Hat, Inc.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1

iQIVAwUBXUAJkdzjgjWX9erEAQjSqQ/+PoRxLYZZ2ANdNtetgulyqBs0tvOIp3Ib
tmEbX4aXq5lb9T+GV8Keq+qHkoTs5OuQ6W6a9/ffkJkNA2EuX5P2FgzqSnGU7j1F
qNoGdL1YMp8pZ84CicoSFepyCpPhT5cneNizUMy/SNHKHGTh1oIJupIa1YtKbzBM
bivxNZRIhigeXMNYxoPorvsWvlzBnfc6GYpPWo6tgQHsMjbSXo0BDkdrXjGPG+TX
Ly82ePaCwPbVFGdW8fBk6S93jdLVlxGoQ4JDp6o2VtfC9+O1/oL3HdyJlxy9qbHo
Z/wDfan5iJjiVVPQVd1PEyihtxyOxwJnaE6qUGOBP3b46AKUZ144+lbcD2WCfcDa
8L9f8eewY5TC5l+LigRxduZaxUn9uHJhPmxzZdfFQE4aiiV6vI2fqlbJri1KFDX5
Lfe6yEJzOTdLPvyBMVfBRFv3+7Ipyk7whvssp3ngwJrDjiHhJ7BB1oQLgoSybF6M
cWzrP/VNPUpT77xb/xXGIhtapoBV3ku5W/r6Hr3fAOo4hiCP9I57IgsTO9fJkdq+
dCbEzcazpR0YiCJhatVjbuJBa/wcFeEj2t70RkszDMwrQ079zK3D20IpvwBfQaMO
YtQfyFsRVeYEz+xj9vLoRLHQ2CwxDe8VKKAK5lI0tnAWL9j/EBoJ0Jv3OdeeLzo2
x51vMVIQoCA=
=ijwu
-----END PGP SIGNATURE-----


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]