[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Bugs, rpm v3.0.4



On Tue, Dec 12, 2000 at 05:42:44PM -0500, Torsten Howard wrote:
> Hello,
> 
> Tried to compile v3.0.4 from tar.gz for linux.
> 
> Function relating to libbz2.a (i.e. bzread, bzdopen, etc)
> do not work.
> 
> Had to prefix these functions in file ./lib/rmpio.c
> with "BZ2_", i.e bzread became BZ2_bzread
> 

Um, bzip2-1.0.1 was released after rpm-3.0.4 and I'm not prescient.

> Second two problems are really similar.  The configure script
> says "warning, need libbz2 to compile rpm"  blah blah.  The
> configure script should crap out at this line, since it is
> absolutely necessary for libbz2.a to be present.  It was on
> my system, just the functions have been renamed, as mentioned
> earlier.
> 

No it isn't necessary for bzip2 to be present, I build rpm all the time
on Red Hat 5.2 w/o bzip.

> This goes for libz.a as well, which I just happened to have
> a copy from binary install of xfree4.0.1.
> 

<shrug> rpm-3.0.x is almost legacy ...

> 
> rpm is version 3.0.4
> bzip2 is version 1.0.1  <note, there is a message in there about fixing
> bzread>
> 

73 de Jeff

-- 
Jeff Johnson	ARS N3NPQ
jbj@jbj.org	(jbj@redhat.com)
Chapel Hill, NC





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index] []