[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: rpmlib(VersionedDependencies) <= 3.0.3-1



Jeff Johnson wrote:
> > Consequently my package fails to install on versions of Linux with
later
> > versions of RPM whereas before adding my versioned dependency it
installed
> > fine.
> >
>
> Hmmm, details please. How does your package "fail to install"? Yes, the
> dependency fails with rpm < 3.0.5, upgrade to rpm-3.0.5, or, if the
> only failure, use --nodeps.

My mistake. I assumed that because the dependency check failed that the RPM
version was greater (I understand that the rpmlib(VersionedDependencies)
version is like an interface or data format version essentially independent
of the version of RPM installed on a system). Once I was able to get on to
the machine where the install was failing I discovered the version of RPM
being used was 3.0.4 on a vanilla RedHat 6.2 system.

Thanks for your help.

Cheers,

Tim Bartley





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index] []