[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Error compiling rpm-4.0



On Sat, Feb 03, 2001 at 05:27:42PM +0000, Detlev Jäckel wrote:
> Hi,
> 
> The installation-instruction tells me to install the db1 and db3 libraries.
> So I installed db-3.1.17 with --enable-compat185 --prefix=/usr/local
> Then making rpm-4.0 I got an Error:
> 

Um, what platform? Presumably non-linux, or you wouldn't have to
be messing with /usr/local ...

FWIW, --enable-compat185 enables only db1 API compatibility, there
are nastier on-disk comaptibility problems as well. I wouldn't bother
with db1 on non-linux platforms.

I also wouldn't bother trying to build rpm-4.0 for non-linux, it's not
worth the pain. Try rpm-4.0.1 from
	ftp://ftp.rpm.org/pub/rpm/test-4.0.1
as that version no longer requires both db1 (db-1.85, not compat185)
and db3 IIRC.

An rpm configure sets the following defines by checking for
	1) HAVE_DB1_DB_H	/usr/include/db1/db.h
	2) HAVE_DB3_DB_H	/usr/include/db3/db.h
	3) USE_DB1		dbopen() in libc.a/libdb1.a/libdb.a
	4) USE_DB3		db_create() in libdb-3.1.a/libdb-3.0.a/libdb.a
using usual autoconf conventions chasing includes and libraries.

I've given up on trying to automagically autoconfigure Berkeley db support
in rpm, as there are far too many bizarre issues with names, paths, platforms,
etc to deal with.

73 de Jeff

-- 
Jeff Johnson	ARS N3NPQ
jbj@jbj.org	(jbj@redhat.com)
Chapel Hill, NC





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index] []