[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re[2]: Need help in building my first RPM



Hello Malcolm,
Thanks did not see that as the problem it works now. What do you no!

Tuesday, August 06, 2002, 11:59:33 PM, you wrote:


MT> On Wed, Aug 07, 2002 at 12:05:46AM -0700, Richard Kurth wrote:
>> 
>> I can't figure out what I am doing wrong I keep getting the error
>> messages below all I what the RPM to do is un-tar a file and copy the
>> files to a directory in the /usr directory. Below the error message
>> is a copy of my spec file.  Please be nice this is my first attempt at
>> making a RPM and I do best with examples.
>> 
>> 
>> Executing(%prep): /bin/sh -e /var/tmp/rpm-tmp.28860
>> + umask 022
>> + cd /usr/src/redhat/BUILD
>> + rm -rf /usr/src/redhat/BUILD/autoserv
>> + zcat /usr/src/redhat/SOURCES/autocontrolpro-3.0.tar.gz
>> + tar -xf -
>> + exit 0
>> Executing(%install): /bin/sh -e /var/tmp/rpm-tmp.96325
>> + umask 022
>> + cd /usr/src/redhat/BUILD
>> + cp /usr/src/redhat/BUILD/autoserv usr/
MT>    ^^^^^^
MT>    Here's the problem.

MT> When copying directories, you want to do something like 'cp -a ...'.

MT> For future debugging, try the command that is failing on the command
MT> line and see if it fails there also. In this case it would have, which
MT> indicates your problem is not rpm related -- it is a shell scripting
MT> problem.

MT> Cheers,
MT> Malcolm



MT> _______________________________________________
MT> Rpm-list mailing list
MT> Rpm-list@redhat.com
MT> https://listman.redhat.com/mailman/listinfo/rpm-list



-- 
Best regards,
 Richard                            mailto:rkurth@starband.net





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index] []