[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: More probs with rpm 4.0.4



On Thu, Aug 29, 2002 at 07:57:56PM +0100, DaClink wrote:
> 
> 
> -----Original Message-----
> From: rpm-list-admin@redhat.com [mailto:rpm-list-admin@redhat.com] On
> Behalf Of Jeff Johnson
> Sent: 29 August 2002 19:28
> To: rpm-list@redhat.com
> Subject: Re: More probs with rpm 4.0.4
> 
> 
> On Thu, Aug 29, 2002 at 07:17:48PM +0100, DaClink wrote:
> > Hi...
> > Having replaced the configure file in the db3 directory of rpm4.0.4 
> > (as
> > suggested) the install gets slightly further...
> > 
> > ./autogen.sh -noconfigure
> > ./configure
> > Completes its run, and there don't seem to be any errors, however on 
> > running Make
> > The following error appears.
> > 
> > 
> > rpmdb.c: In function `miregexec':
> > rpmdb.c:1654: warning: implicit declaration of function `fnmatch'
> > make[2]: *** [rpmdb.lo] Error 1
> > make[2]: Leaving directory `/usr/src/working/rpm-4.0.4/rpmdb'
> > make[1]: *** [all-recursive] Error 1
> > make[1]: Leaving directory `/usr/src/working/rpm-4.0.4'
> > make: *** [all-recursive-am] Error 2
> 
> You need to compile misc/fnmatch.c, and link with -lmisc.
> 
> How do I do this... (I'm a relative newbie)

Make a bug report at http://bugzilla.redhat.com and I'll get you straightened
out.

I'm gonna need to know:
	What platform?
	How did you configure rpm?

73 de Jeff

-- 
Jeff Johnson	ARS N3NPQ
jbj@redhat.com (jbj@jbj.org)
Chapel Hill, NC





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index] []