[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: unpacking of archive failed: cpio: Bad magic



On Wed, Feb 13, 2002 at 03:23:22PM -0800, Sean McNair wrote:
> Found this same question in the archives, but the user mentioned hard
> disk errors.  I've tried different drives and different hosts to
> eliminate this, but have the same problem.  I'm using rpm 3.0.4 on i386
> RedHat 7.1 (don't ask).  Anyhow I get this error with one particular
> package (12 others worked fine).  Any pointers would be helpful.

I'm tempted to ask, as rpm-3.0.4 on Red Hat 7.1 is, well, kinda weird.
Someone had to work pretty hard to achieve that :-) No matter.

What does rpm -K say about the package that's failing?

I predict that you'll find a corrupted package. In fact, the "Bad magic"
error occurs in rpm-3.0.x iff the error is in the magic number field of
a cpio header in the payload, so I'm almost positive the package is
corrupted.

HTH

73 de Jeff

-- 
Jeff Johnson	ARS N3NPQ
jbj@jbj.org	(jbj@redhat.com)
Chapel Hill, NC





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index] []