[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Newbie build question



Jeremy_Banks@tab.co.nz wrote:

This is a repeat of an earlier post, I have re-subscribed using an email client
that won't give annoying html mail.

Hi,
I have previously worked on SuSe and so I'm having my first go at using RPMs
instead of tarballs. I was trying to install the epca package and ran in to a
few problems. I'm running Redhat 7.2 and rpm 4.0.3. I copied the src rpm
4001450N.src.rpm to /usr/src and did the following:
$ cd /usr/src
$ mkdir redhat
$ rpm -ivh 4001450N.src.rpm

This appeared to work and created the files
/usr/src/redhat/SOURCES/epca-1.50-1.tar.gz and /usr/src/redhat/SPECS/epca.spec.
I then tried:

$ rpm -bb /usr/src/redhat/SPECS/epca.spec

And received the error:
/usr/src/redhat/SPECS/epca.spec: No such file or directory

The file is definitely there and no matter what build option I give rpm (-bp,
-bb, -ba) it complains about the file not being there. I also tried changing
into all sorts of different directories and referencing the spec file in all
sorts of different ways, but nothing seemed to make it work. Rpm simply can't
see the file for some reason.

Check permissions on the spec file and all leading directories (it looks like you are building as non-root, which is the Right Thing To Do). If that fails, strace is your friend. Try strace -ff -o /tmp/rpm.strace rpm -bb /usr/src/redhat/SPECS/epca.spec, and look for the syscalls which precede the printing of the error message. You will want to look at the files /tmp/rpm.strace*.

Regards,
Brian






[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index] []