[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Installed glibc-3.2.2, now RPM segfaults



In order to install gcc-3.2.2, I tried upgrade the Glibc on my RH-7.3 box
to 2.3.2 (from 2.2.5-?). The only dependency problem encountered was
with binutils so I upgraded it first and then successfully upgraded
Glibc. Now RPM doesn't install, upgrade or erase any RPMs. When I run
[mybox]# rpm -Uvh rpmfile.rpm, I get the "preparing" message and the
hash marks up to 100% but at that point I get a seg fault. It doesn't
matter if I use -Uvh, -ivh --force -- nodeps -e or any combination, I
always get the same thing, "preparing" to 100% and then the seg fault.
I can use query and list and so forth, but none of the install or erase
functions work. I can't roll Glibc back to the previous version because
RPM seg faults every time and I can't install gcc because of the seg
fault. I did try --rebuilddb and it ran to completion without problem
but it didn't fix the seg fault. Have I hosed my system? Can someone
offer some suggestions to get RPM working again? I've thought of
installing the latest RPM from source, but I'm afraid that may destroy
the rpm database.

Thanks,
Rick Knight
(rick@rlknight.com)





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index] []