[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

%files list problem on Solaris



I am trying to use rpm-4.2 on Solaris 8.

If I specify a directory that contains another directory in %files, then
then rpmbuild -ba stops at:

make[1]: Leaving directory `/home/asterr/src/sRPM/ts-glib/glib-2.2.0/docs'
+ exit 0 
Processing files: ts-glib-2.2.0-1



If I specify each individual file (to make sure I do not hit the problem
case) then the next line after "Processing files..." is as below, and the
build will complete.

Requires(rpmlib): rpmlib(CompressedFileNames) <= 3.0.4-1 rpmlib(PayloadFilesHavePrefix) <= 4.0-1


I have dug through the code trying to find what may be breaking, but I have
gotten lost.  Does anyone have any pointers?  Is this a problem in 
recurseDir in files.c?

This problem does not happen for rpm 4.1 on the same machine.


-- 
Aaron Sterr - Infrastructure Engineer
TradingScreen Inc.
Tel: +81(3)3568-2022
Fax: +81(3)3583-8520
-----------------------------------------

This message and any attachments (the "message") are intended solely for the
addressees and are confidential.  If you receive this message in error, please
delete it and immediately notify the sender. Any use not in accordance with its
purpose, any dissemination or disclosure, either whole or partial, is prohibited
except with formal approval. The integrity of messages transmitted over the
Internet cannot be guaranteed. TradingScreen (and its affiliates) shall (will)
not therefore be liable for the message if modified.




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]