[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Compatibility of API across versions 4.0 - 4.2 - and RPM frontendin C



On Thu, 11 Dec 2003, Ram Prakash. R wrote:

> Hi folks,
>    Can anybody tell me if an application written for rpm4.0 API be 
> compatible with 4.2. I would like to write an application in C that will 
> install/upgrade applications that I create.

No it wont, unfortunately. rpm 3.*, rpm 4.0.* and rpm >= 4.1 have quite 
distinct API's, from 4.1 upwards fortunately the API has remained almost 
unchanged. 

> 
>     Also, is there any such application written in C which I can refer 
> for the usage of the rpmlib APIs. I downloaded gnorpm but I find that 
> many functions like rpmRunTransactions are not present in the latest RPM 
> 4.2 version.

Check out apt-rpm >= 0.5.15cnc3 (http://moin.conectiva.com.br/AptRpm), it
supports all major versions from 3.0.x to 4.2.1 using the rpmlib API and
written in C++ (which, while not exactly C should be close enough for you
to figure out the API usage and especially the differences between rpm
versions). Or better yet, grab the repository head from
https://oops.kerneljanitors.org/repos/apt-rpm/trunk/ (it's a subversion
repository), it now has generic rpm version detection making supporting
several versions much nicer than what it was.

Oh and the stuff you're interested in lives in apt-pkg/rpm/ directory :)

	- Panu -




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]